[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[FOLLOW-UP] Re: [FC3] kernel panic after selinux-policy-targeted update

On Mon, 2005-06-27 at 15:22 +0100, D. D. Brierton wrote:
> I ran sudo yum update today and selinux-policy-targeted was updated 
> (along with another selinux related package whose name I can't remember) 
> and immediately my system became unresponsive and I had to do a hard reboot.
> Now I cannot boot into FC3 at all (I'm posting this from Windows). This 
> is the error I get:
> audit(1119882959.657:0): avc: denied { execmod } for pid=1 comm=init 
> path=/lib/tls/libc-2.3.5.so dev=hda3 ino=2638668 
> scontext=user_u:system_r:unconfined_t tcontext=system_u:object_r:shlib_t 
> tclass=file
> /sbin/init: error while loading shared libraries : /lib/tls/libc.so.6: 
> cannot apply additional memory protection after relocation: Permission 
> denied
> Kernel panic - not syncing: Attempted to kill init!

Well I rebooted using enforcing=0 (rather than selinux=0) successfully.
I then did the following:

su -
rpm -ev selinux-policy-targeted selinux-policy-targeted-sources
rm -fR /etc/selinux/targeted/
rpm -ivh /var/cache/yum/updates-released/packages/selinux-policy-targeted-1.17.30-3.9.noarch.rpm /var/cache/yum/updates-released/packages/selinux-policy-targeted-sources-1.17.30-3.9.noarch.rpm
touch /.autorelabel

and everything worked fine. Thanks Paul, Alexander and Stephen.

Once I was confident that I could easily revert back to a working
system, I thought I would try the updated 1.17.30-3.13 packages again.
So I removed the cached versions of the packages, downloaded them
manually, and then repeated the steps above so that instead of upgrading
the packages I did a completely clean install of them. This time the
system didn't become unstable but again I couldn't reboot, for exactly
the same reason as before. I don't know why only I seem to be suffering
from this problem, but I've bugzillaed it:


Thanks again for the help.

Best, Darren

D. D. Brierton            darren dzr-web com          www.dzr-web.com
       Trying is the first step towards failure (Homer Simpson)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]