[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [FOLLOW-UP] Re: [FC3] kernel panic after selinux-policy-targeted update



On Mon, Jun 27, 2005 at 05:54:29PM +0100, D. D. Brierton wrote:
> On Mon, 2005-06-27 at 15:22 +0100, D. D. Brierton wrote:
> > I ran sudo yum update today and selinux-policy-targeted was updated 
> > (along with another selinux related package whose name I can't remember) 
> > and immediately my system became unresponsive and I had to do a hard reboot.
> > 
> > Now I cannot boot into FC3 at all (I'm posting this from Windows). This 
> > is the error I get:
> > 
> > audit(1119882959.657:0): avc: denied { execmod } for pid=1 comm=init 
> > path=/lib/tls/libc-2.3.5.so dev=hda3 ino=2638668 
> > scontext=user_u:system_r:unconfined_t tcontext=system_u:object_r:shlib_t 
> > tclass=file
> > /sbin/init: error while loading shared libraries : /lib/tls/libc.so.6: 
> > cannot apply additional memory protection after relocation: Permission 
> > denied
> > Kernel panic - not syncing: Attempted to kill init!
> 

FWIW, I'm receiving similar avc messages/errors, as are others:

https://www.redhat.com/archives/fedora-selinux-list/2005-June/msg00240.html

I tried to ssh to the borked machine to try and fix the problem, but
even that isn't possible (I get an immediate
"ssh_exchange_identification: Connection closed by remote host"
error).  Thanks for posting the fix, I guess I need to wait until I
can physically access the machine to try it.

Regards,
Tim

-- 
Morals?  I eat communism and $h!t America, brother.  --Seanbaby


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]