[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Kudo's again to the Fedora Team



Ted Kaczmarek wrote:

> Finished my yum upgrade yesterday and FC4 is another great leap forward.
> Only issue I had was I needed to upgrade minitrd from FC3 version to FC4
> version, otherwise the yum upgrade faq was right on.
> 
> Thanks out to the whole team for making computing so enjoyable.

Sadly I have to disagree.
I have upgraded from FC-3 to FC-4 on 5 rather different computers,
and had serious problems on 3 of the 5, 
and a lesser problem on a fourth (with the x86_64 distribution).

My experience is that Fedora is getting worse from this point of view -
ability to upgrade or install - not better.

My latest problem was with a Sony Picturebook C1VFK.
I started to upgrade using CDs, duly checked.
I gave the magic command "linux text ide1=0x180,0x386"
as advised in the Release Notes.
(Well, I had to add the "text" because when I tried
using the standard graphics installation
the bottom of the pages did not appear on my (small) screen,
and there did not appear to be any way to get to them.)

In any case, the above command allowed me to boot from CD#1,
and to start the upgrade from this CD.
However, the installation bombed out when the time came
to put in CD#2.
This left the machine in a fairly unusable state.
Fortunately I was able to use "yum update" 
to install the rest of the distribution.
(This took 9 hours.)

I like Fedora once it is installed and running.
But why oh why can't the Anaconda team
look at the other Linux distributions,
and see what it is they are doing right
and Anaconda is doing wrong?

I've filed bugzillas about the problems I've encountered
over the years with Fedora,
but never had the impression anyone felt it was their job
to try to get Fedora working on different machines.
I've actually been told on several occasions
that my problem is that I am using "non-standard" hardware.

I have to admit that one thing does now work on my Picturebook
which hasn't worked for a year or more -
the latest version of X (xorg-x11) has corrected a bug
which prevented it running on this machine.
There has been a patch available for a couple of years,
and I've had to re-compile X with the patch included, until now,
despite myself and others pointing out in bugzillas and elsewhere
that it was necessary to apply this (tiny) patch.



-- 
Timothy Murphy  
e-mail (<80k only): tim /at/ birdsnest.maths.tcd.ie
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College, Dublin 2, Ireland


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]