[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Kernel Panic after FC4 upgrade



Hi, folks,

I recently updated from FC3 to FC4 via CD install. Install went fairly smoothly, but I now can't get the system to boot--I get a kernel panic. Relevant section of boot log follows (apologies for any typos--I can't cut-and-paste this without a working system...)
CODE


Mounting root filesystem
mount: error 6 mounting ext3
Switching to new root
ERROR opening /dev/console!!!!: 2
error dup2'ing fd of 0 to 0
error dup2'ing fd of 0 to 1
error dup2'ing fd of 0 to 2
unmounting old /proc
unmounting old /sys
switchroot: mount failed: 22
Kernel panic - not syncing: Attempted to kill init!


Having done some poking here and on google, I'm expecting this is a grub issue with finding my proper root filesystem, since it seems to have issues when it tries to mount the root device. Which should be trivial to fix, so I'm sure I'm missing something obvious here. But I've been at this for several hours, and can't for the life of me find the issue...


Some configuration info: I'm attempting to boot from a SCSI raid array. That array has /boot on /dev/sda1, the correct root filesystem on /dev/sda2, and /swap on /dev/sda3. I'm using the smp kernel because I do have an SMP system. I know the array is OK because I can properly mount it when booting into rescue mode.

I've looked at grub.conf and didn't see any obvious issues, though I've tried a few suggestions I've found online. I've tried reinstalling grub on /dev/sda. I've run grub and verified that it has setup hd0. I've checked the device map, which looks OK. I do note fedora is using hd0 in grub, not sd0, to represent my array, but since the device map correctly points to the right place, I don't think that would be an issue (especially given that the system can in fact find the kernel). Basically, I'm stuck here, and looking for some thoughts/suggestions:

Some possibly useful files follow:
/etc/grub.conf looks like:
CODE

# grub.conf generated by anaconda
#
#Note that you do not have to rerun grub after making changes to this file
#NOTICE:  You have a /boot partition.  This means that
#               all kernel and initrd paths are relative to /boot/, eg.
#               root (hd0,0)
#               kernel /vmlinuz-version ro root=/dev/sda2
#               initrd-version.img
#boot=/dev/sda
default=1
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Fedora Core (2.6.11-1.1369_FC4smp)
   root (hd0,0)
   kernel /vmlinuz-2.6.11-1.1369_FC4smp ro root=/dev/sda2
   initrd /initrd-2.6.11-1.1369_FC4smp.img
title Fedora Core (2.6.11-1.1369_FC4)
   root (hd0,0)
   kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=/dev/sda2
   initrd /initrd-2.6.11-1.1369_FC4.img


/boot/grub/device-map looks like: CODE

#this device map was generated by anaconda
(fd0)    /dev/fd0
(hd0)   /dev/sda


/etc/fstab looks like: CODE

/dev/sda2      /              ext3     defaults               1 1
/dev/sda1      /boot        ext3     defaults               1 2
none             /dev/pts    devpts  gid=5,mode=620 0 0
none             /proc        proc      defaults              0 0
none             /dev/shm  tmpfs    defauls               0 0
/dev/sda3      /swap       swap     defauls               0 0
<more in this file about my IDE hard drives and floppy>


Any suggestions greatly appreciated!!!!

_________________________________________________________________
Don’t just search. Find. Check out the new MSN Search! http://search.msn.click-url.com/go/onm00200636ave/direct/01/



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]