[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: FC4 good new tech, bad legacy support



just out of curiosity, is there some place/wiki/etc.. where a user can go to
check a given version of FC/Linux, and see what OS/Motherboard-Hardware
config/apps work together...

IE, like one big/searchable database!!! allow users to put in their
information, in terms of what they see. at the same time, allow
developers/maintainers of software/rpms to add information as well...

thoughts/comments/etc...

-bruce


-----Original Message-----
From: fedora-list-bounces redhat com
[mailto:fedora-list-bounces redhat com]On Behalf Of Rahul Sundaram
Sent: Thursday, June 30, 2005 2:20 AM
To: For users of Fedora Core releases
Cc: liu chang
Subject: Re: FC4 good new tech, bad legacy support


Richard Kelsch wrote:

> Ok people, I'm not trying to be a bummer here, so please read this as
> if it was meant to entertain, not insult.  Think of me as a whining
> comic.  However, there is a seriousness to the root of this message:
>
> After installing FC4 I was impressed with all of the new features,
> speed and such.  As a stand alone OS, it is superb.  For me,
> everything "stock" worked "out of the box."  All hail Fedora Core 4!
> I was singing praises, people were on the streets in awe.  Life was
> good.  The installation went well, it operated well, everything that
> was installed from the "core" or "extras" binary rpms worked superb...
>
> However, I noticed after I started installing software I needed
> (gzipped sourcem CPAN modules etc.), it's not very compatible with
> older "legacy" software.  In fact, as a rule, getting software not in
> the "core", "extras", or "freshrpms" trees to work is a royal pain in
> the fanny.  Nothing compiles without errors.  In fact, luck is a big
> factor getting anything to work once you think you've got it
> compiled.  This isn't an issue with only one piece of software,
> otherwise I'd consider myself ranting.  No, I'm not going to file
> numerous bug reports for things I'm not exactly sure where the bug
> is.  Yes, I had tried the gcc32 trick as well, and nothing works like
> it should.

If the software doesnt work with either gcc 3.2 or gcc 4.x then its
probably broken. GCC 4.x is there as the primary compiler. compat-gcc-32
for legacy support. I am not sure what else could be done better here.
any ideas?

regards
Rahul

--
fedora-list mailing list
fedora-list redhat com
To unsubscribe: http://www.redhat.com/mailman/listinfo/fedora-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]