[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: building kde apps (amarok)



On Thu, 30 Jun 2005 13:58:59 -0400, ne... wrote:

> > Patrick Steiner wrote:
> > 
> > > i have tryed to compile an svn version of amarok, but i alway get the
> > > error that my compiler ist blacklistet. is there any workaround do
> > > build amarok (or other kde apps) from source?
> > 
> > yum install compat-gcc-32
> > 
> > You'll need to export CC=gcc32 prior to compiling.
> > 
> >         Thanks go to mick means for this answer in a previous post, as I ama noob!
> Considering that FC4 was built with gcc v4, and this includes qt and KDE,
> has anyone had any problems compiling and using KDE apps with gcc-32?

I would assume that they fail to link because of C++ ABI incompatibility.
Better patch out the GCC4 check from the "configure" script. Should not be
much more than a single block of shell code that does the check.

-- 
Michael Schwendt <mschwendt users sf net>
Fedora Core release 4 (Stentz) - Linux 2.6.12-1.1385_FC4
loadavg: 2.85 2.59 2.22


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]