[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

system-config-cluster error



I am configuring a cluster of 2 HP machines and I just installed Fedora Core 4 on both machines with the proper services to run a cluster and share resources. I managed to share a disk array as a single partition with both machine by the Global File System.

To further configure the cluster I installed the system-config-cluster RPM package as suggested by the documentation which anyway is not part of the Fedora Core 4 CDs. I found it on rpmfind and installed with an rpm -i command. I can start the application and make changes but if I try to save them I get the following trace.

[root AICLSRV01 cluster]# Traceback (most recent call last):
  File "/usr/sbin/system-config-cluster", line 435, in propagate
    if self.model_builder.exportModel(CLUSTER_CONF_PATH) == True:
File "/usr/share/system-config-cluster/ModelBuilder.py", line 361, in exportModel
    if self.perform_final_check() == False: # failed
File "/usr/share/system-config-cluster/ModelBuilder.py", line 780, in perform_final_check
    self.check_two_node()
File "/usr/share/system-config-cluster/ModelBuilder.py", line 806, in check_two_node
    self.CMAN_ptr.addAttribute('two_node', '1')
AttributeError: 'NoneType' object has no attribute 'addAttribute'

Anybody can help me to make it work? Or perhaps should I get a different package? The one I downloaded is system-config-cluster-1.0.24-1.0.noarch.rpm. Thanks in advance.

--
Fabrizio Lippolis
fabrizio lippolis aurigainformatica it
Auriga Informatica s.r.l.
Via Don Guanella 15/B - 70124 Bari
Tel.: 080/5025414  Fax: 080/5027448


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]