[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Xen Boot Error under FC4



On Tue, 2006-03-07 at 13:09 +0530, Parameshwara Bhat wrote:
> Hello List,

> I was trying to learn Xen on my PIII (celeron 450 Mhz)system with 256 MB  
> of RAM.I have installed xen through yum(kyum)

> [pbhat sidharth ~]$ rpm -qa|grep xen
> kernel-xenU-2.6.13-1.1532_FC4
> xen-2-20050823
> kernel-xen0-2.6.13-1.1532_FC4

> This is my grub.conf entry as given by installer.Though the package Xen is  
> version 2, entris in
> /boot suggest version 3.0

> title Fedora Core (2.6.13-1.1532_FC4xen0)
>          root (hd0,0)
>          kernel /xen.gz
>          module /vmlinuz-2.6.13-1.1532_FC4xen0 ro  
> root=/dev/VolGroup00/LogVol00 selinux=0 rhgb quiet
>          module /initrd-2.6.13-1.1532_FC4xen0.img

> When I boot from this entry,XEN stops loading domain0 with the massage  
> 'allocated memory is too low for domain0'. I tried giving full system  
> memory with ----

> title Fedora Core (2.6.13-1.1532_FC4xen0)
>          root (hd0,0)
>          kernel /xen.gz  dom0_mem=256M noreboot acpi=off
>          module /vmlinuz-2.6.13-1.1532_FC4xen0 ro  
> root=/dev/VolGroup00/LogVol00 selinux=0 rhgb quiet
>          module /initrd-2.6.13-1.1532_FC4xen0.img.

> Could anybody suggest where's the error?

	The error is trying to use Xen on FC4 with a recent FC4 kernel.  Sorry,
but it looks like they gave up on Xen on FC4 some time ago.  I think the
last kernel I saw where Xen worked was 2.6.12-1.1456 and it was
definitely busted on 2.6.13-1.1532.  The non-Xen kernels are now up to
2.6.15-1.1833 and I haven't seen a Xen update since 2.6.13-1.1532 and
that was from late last year and it didn't work for the reasons you've
noted.

	Rik van Reil had posted a link to some kernels a while back and I had
tried those for a bit.

	There is this bugzilla report on the problem:

	https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169157

	You will note that the thread ends with Rik remarking that, "This bug
has been fixed in Fedora Core 5 rawhide Xen images."  That never seems
to have made its way into the FC4 updates.

	So, your choices seem to be to move to an FC5 kernel or fall back to an
earlier kernel (if you can find one) that might work (but will have
other problems, as I learned).

> Thanks,

> Parameshwara Bhat

	Mike
-- 
Michael H. Warfield (AI4NB) | (770) 985-6132 |  mhw WittsEnd com
   /\/\|=mhw=|\/\/          | (678) 463-0932 |  http://www.wittsend.com/mhw/
   NIC whois: MHW9          | An optimist believes we live in the best of all
 PGP Key: 0xDF1DD471        | possible worlds.  A pessimist is sure of it!

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]