[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Missing Dependency: libavcodec.so.51



On Tue, 2006-03-07 at 06:56 -0600, Rex Dieter wrote:
> Craig McLean wrote:
> 
> > Joao Paulo Pires wrote:
> 
> >>When I update (FC4) I got this message:
> >>Error: Missing Dependency: libavcodec.so.51 is needed by package xine-lib
> 
> >>In fact xine it’s ok but is missing that file.
> 
> > Joao,
> > Use "yum provides"...
> > 
> > [root songspire ~]# yum provides libavcodec.so.51
> 
> > So it's available in the "ffmpeg" package, revision
> > 0.4.9-0.lvn.0.20.20051, from the Livna repo...
> 
> Unfortunately, livna and freshrpms currently have incompatible versions 
> of ffmpeg.  livna's is really newer, but freshrpm's version is newer 
> because of their choice of Release tags.
> 
Just another example of why you should not enable multiple repos for
routine updates.  The incompatible packages drive you into dependency
hell.

> -- Rex
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]