[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Still no joy with yum



On Tuesday 07 March 2006 23:59, you wrote:
> On Tue, 2006-03-07 at 23:47 -0600, Bruce Bales wrote:
> > On Tuesday 07 March 2006 23:29, you wrote:
> > > On Tue, 2006-03-07 at 23:22 -0600, Bruce Bales wrote:
> > > > On Tuesday 07 March 2006 23:04, Craig White wrote:
> > > > > On Tue, 2006-03-07 at 22:54 -0600, Bruce Bales wrote:
> > > > >
> > > > > Please - this should be on fedora-list, not personal mail
> > > > > ----
> > > > >
> > > > > > I don't think it matters, but I will mention that all these
> > > > > > repositories are in /etc/yum.repos.d/  Not /etc/yum.repos/
> > > > >
> > > > > ----
> > > > > yes, you are correct...I'm trying to concentrate on some
> > > > > programming ----
> > > > >
> > > > > > I edited livna.repo and added enabled=0 to both livna-unstable
> > > > > > and livna-testing, then ran sudo yum install mplayer and
> > > > > > redirected to yum-out with 2>&1.  Then:
> > > > >
> > > > > ----
> > > > > OK - I had expected to see some other things here...
> > > > > ----
> > > > >
> > > > > > [bruce blacky yum.repos.d]$ cat /tmp/yum-out.txt
> > > > > > Error: Missing Dependency: libfribidi.so.0 is needed by package
> > > > > > mplayer Error: Missing Dependency: libxmms.so.1 is needed by
> > > > > > package mplayer Repository updates-released already added, not
> > > > > > adding again Repository base already added, not adding again
> > > > > > Setting up Install Process
> > > > > > Setting up Repos
> > > > > > Reading repository metadata in from local files
> > > > > > Parsing package install arguments
> > > > > > Resolving Dependencies
> > > > > > --> Populating transaction set with selected packages. Please
> > > > > > wait. ---> Package mplayer.i386 0:1.0-0.lvn.0.33.pre7try2.3 set
> > > > > > to be updated --> Running transaction check
> > > > > > --> Processing Dependency: libdvdread.so.3 for package: mplayer
> > > > > > --> Processing Dependency: libfaad.so.0 for package: mplayer
> > > > > > --> Processing Dependency: liblzo.so.1 for package: mplayer
> > > > > > --> Processing Dependency: libaa.so.1 for package: mplayer
> > > > > > --> Processing Dependency: libmad.so.0 for package: mplayer
> > > > > > --> Processing Dependency: libenca.so.0 for package: mplayer
> > > > > > --> Processing Dependency: libmp3lame.so.0 for package: mplayer
> > > > > > --> Processing Dependency: libfribidi.so.0 for package: mplayer
> > > > > > --> Processing Dependency: mplayer-fonts >= 1.1-0.lvn.2 for
> > > > > > package: mplayer --> Processing Dependency: liblirc_client.so.0
> > > > > > for package: mplayer --> Processing Dependency: libxmms.so.1 for
> > > > > > package: mplayer --> Restarting Dependency Resolution with new
> > > > > > changes.
> > > > > > --> Populating transaction set with selected packages. Please
> > > > > > wait. ---> Package lzo.i386 0:1.08-2 set to be updated
> > > > > > ---> Package lame.i386 0:3.96.1-0.lvn.4.3 set to be updated
> > > > > > ---> Package aalib.i386 0:1.4.0-0.rc5.3 set to be updated
> > > > > > ---> Package lirc.i386 0:0.7.1-1 set to be updated
> > > > > > ---> Package faad2.i386 0:2.0-0.lvn.5.3 set to be updated
> > > > > > ---> Package libdvdread.i386 0:0.9.4-0.lvn.1.3 set to be updated
> > > > > > ---> Package enca.i386 0:1.9-1.fc3 set to be updated
> > > > > > ---> Package libmad.i386 0:0.15.1-0.lvn.1.b.3 set to be updated
> > > > > > ---> Package mplayer-fonts.noarch 0:1.1-0.lvn.3.3 set to be
> > > > > > updated --> Running transaction check
> > > > > > --> Processing Dependency: libdvdcss >= 0:1.2.5 for package:
> > > > > > libdvdread --> Processing Dependency: libxmms.so.1 for package:
> > > > > > mplayer --> Processing Dependency: libfribidi.so.0 for package:
> > > > > > mplayer --> Restarting Dependency Resolution with new changes.
> > > > > > --> Populating transaction set with selected packages. Please
> > > > > > wait. ---> Package libdvdcss.i386 0:1.2.9-0.lvn.1.3 set to be
> > > > > > updated --> Running transaction check
> > > > > > --> Processing Dependency: libxmms.so.1 for package: mplayer
> > > > > > --> Processing Dependency: libfribidi.so.0 for package: mplayer
> > > > > > --> Finished Dependency Resolution
> > > > >
> > > > > -----
> > > > > let's try...
> > > > >
> > > > > sudo yum clean all  # clear out who know what is in
> > > > > /var/cache/yum...
> > > > >
> > > > > sudo yum update # let's make sure we've got a good base...
> > > > >
> > > > > sudo yum install mplayer # then we try again...
> > > > >
> > > > > Craig
> > > >
> > > > [When I click on 'Reply' I have to pay attention to what gets into
> > > > the 'TO' spot.]
> > > > I did the yum clean and yum update then yum install mplayer and it
> > > > looks the same to me.
> > > >
> > > > [bruce blacky yum.repos.d]$ sudo yum install mplayer >
> > > > /tmp/yum-out2.txt 2>&1 [bruce blacky yum.repos.d]$ cat
> > > > /tmp/yum-out2.txt
> > > > Error: Missing Dependency: libfribidi.so.0 is needed by package
> > > > mplayer Error: Missing Dependency: libxmms.so.1 is needed by package
> > > > mplayer Repository updates-released already added, not adding again
> > > > Repository base already added, not adding again
> > > > Setting up Install Process
> > > > Setting up Repos
> > > > Reading repository metadata in from local files
> > > > Parsing package install arguments
> > > > Resolving Dependencies
> > > > --> Populating transaction set with selected packages. Please wait.
> > > > ---> Downloading header for mplayer to pack into transaction set.
> > > > ---> Package mplayer.i386 0:1.0-0.lvn.0.33.pre7try2.3 set to be
> > > > updated --> Running transaction check
> > > > --> Processing Dependency: libdvdread.so.3 for package: mplayer
> > > > --> Processing Dependency: libfaad.so.0 for package: mplayer
> > > > --> Processing Dependency: liblzo.so.1 for package: mplayer
> > > > --> Processing Dependency: libaa.so.1 for package: mplayer
> > > > --> Processing Dependency: libmad.so.0 for package: mplayer
> > > > --> Processing Dependency: libenca.so.0 for package: mplayer
> > > > --> Processing Dependency: libmp3lame.so.0 for package: mplayer
> > > > --> Processing Dependency: libfribidi.so.0 for package: mplayer
> > > > --> Processing Dependency: mplayer-fonts >= 1.1-0.lvn.2 for package:
> > > > mplayer --> Processing Dependency: liblirc_client.so.0 for package:
> > > > mplayer --> Processing Dependency: libxmms.so.1 for package: mplayer
> > > > --> Restarting Dependency Resolution with new changes.
> > > > --> Populating transaction set with selected packages. Please wait.
> > > > ---> Downloading header for lzo to pack into transaction set.
> > > > ---> Package lzo.i386 0:1.08-2 set to be updated
> > > > ---> Downloading header for lame to pack into transaction set.
> > > > ---> Package lame.i386 0:3.96.1-0.lvn.4.3 set to be updated
> > > > ---> Downloading header for aalib to pack into transaction set.
> > > > ---> Package aalib.i386 0:1.4.0-0.rc5.3 set to be updated
> > > > ---> Downloading header for lirc to pack into transaction set.
> > > > ---> Package lirc.i386 0:0.7.1-1 set to be updated
> > > > ---> Downloading header for faad2 to pack into transaction set.
> > > > ---> Package faad2.i386 0:2.0-0.lvn.5.3 set to be updated
> > > > ---> Downloading header for libdvdread to pack into transaction set.
> > > > ---> Package libdvdread.i386 0:0.9.4-0.lvn.1.3 set to be updated
> > > > ---> Downloading header for enca to pack into transaction set.
> > > > ---> Package enca.i386 0:1.9-1.fc3 set to be updated
> > > > ---> Downloading header for libmad to pack into transaction set.
> > > > ---> Package libmad.i386 0:0.15.1-0.lvn.1.b.3 set to be updated
> > > > ---> Downloading header for mplayer-fonts to pack into transaction
> > > > set. ---> Package mplayer-fonts.noarch 0:1.1-0.lvn.3.3 set to be
> > > > updated --> Running transaction check
> > > > --> Processing Dependency: libdvdcss >= 0:1.2.5 for package:
> > > > libdvdread --> Processing Dependency: libxmms.so.1 for package:
> > > > mplayer --> Processing Dependency: libfribidi.so.0 for package:
> > > > mplayer --> Restarting Dependency Resolution with new changes.
> > > > --> Populating transaction set with selected packages. Please wait.
> > > > ---> Downloading header for libdvdcss to pack into transaction set.
> > > > ---> Package libdvdcss.i386 0:1.2.9-0.lvn.1.3 set to be updated
> > > > --> Running transaction check
> > > > --> Processing Dependency: libxmms.so.1 for package: mplayer
> > > > --> Processing Dependency: libfribidi.so.0 for package: mplayer
> > > > --> Finished Dependency Resolution
> > > > [bruce blacky yum.repos.d]$
> > >
> > > ---
> > > what version of Fedora are you running?
> >
> > It is core 3.
> >
> > > why don't I see fedora-extras listed? Can you provide a
> > > 'cat /etc/yum.repos.d/fedora-extras.repo' ?
> > >
> > > Thanks
> >
> > [bruce blacky yum.repos.d]$ cat /etc/yum.repos.d/fedora-extras.repo
> >
> > ###################
> > ## Fedora Extras ##
> > ###################
> >
> > [extras]
> > name=Fedora Extras - $releasever - $basearch
> > baseurl=http://fr2.rpmfind.net/linux/fedora/extras/$releasever/$basearch/
> >   http://mirrors.kernel.org/fedora/extras/$releasever/$basearch/
> >  
> > http://mirror.hiwaay.net/redhat/fedora/linux/extras/$releasever/$basearch
> >/
> >
> > http://www.mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/
> >linux/extras/$releasever/$basearch/ #
> > http://download.fedora.redhat.com/pub/fedora/linux/extras/$releasever/$ba
> >search/ enabled=1
> > gpgcheck=0
> > gpgkey=http://download.fedora.redhat.com/pub/fedora/linux/extras/RPM-GPG-
> >KEY-Fedora-Extras [bruce blacky yum.repos.d]$
>
> ----
> I think your problem is that you need to install fedora-legacy
> repository to be able to install packages for fedora-base because these
> are base packages and aren't available from fedora proper anymore
> because FC-3 is EOL
>
> see this page for changes that you need to make to yum...
>
> http://www.fedoralegacy.org/download/
>
> I think that will solve your issue - it's important to keep in mind that
> FC-3 has reached EOL and without changing your repositories in yum over
> to fedoralegacy - nothing will be updated.
>
> Craig
Okay, Craig.  Thanks a million.  I think I made a mistake installing FC3.  
With FC5 due out soon it is probably good to think about upgrading to that.  
bruce


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]