[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Addressing a SCSI film-scanner - long, sorry.



Anne Wilson wrote:
On Wednesday 08 March 2006 08:31, Paul Howarth wrote:

On Tue, 2006-03-07 at 22:38 +0000, Anne Wilson wrote:

On Tuesday 07 March 2006 22:18, Paul Howarth wrote:ecognised.


You'll probably need to load a driver for the SCSI card before any of
the devices attached to it will work.

Try:
# modprobe tmscsim

and see if that helps.

Well, the command was accepted.  Should I add that into modprobe.conf?

See if it detected your hardware first. Look in /var/log/messages for
the time that you inserted the module and see if anything relevant
appears.


There is absolutely nothing there for that time.

Not a good sign. You could try "rmmod tmscsim" and then do the modprobe again just to check.

You might also try "cat /proc/scsi/scsi" and see what appears.


No attached devices.

Again, not a good sign,

If that shows your scanner, then you've got the right module. Add:

alias scsi_hostadapter tmscsim

to /etc/modprobe.conf


tmscsim is the scsi adapter driver, not the scanner itself, and system-config-control Hardware Browser does see the adapter (and lists the driver as tmscsim.

Uf it was the right SCSI driver (I'm not convinced about that), you *might* need to also load the "sg" (SCSI Generic) module before the Hardware Browser could see an attached scanner. You'd certainly need the sg module to use the scanner with SANE. However, the empty /proc/scsi/scsi suggests to me that the tmscsim module is not the one you need for your card.

I got further than this three years ago when I tried to run the scanner under Mandrake, so I know that it's possible to get it recognised. I failed to install the driver patch then, and it froze the system, but at least it tried to work. I only mention this to indicate that it isn't an incompatible piece of equipment.

Three years ago you might have been using a different driver.

There are some scanner-related hints at http://www.garloff.de/kurt/linux/dc390/problems.html which might be appropriate for you.

Is there any relevance at all in the fact that all my FC4 boxes show messages entries about automount being unable to find .directory?

Dunno.

Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]