[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Loading modules on-demand does not work with a stock FC4 kernel



Hello all.

I'm stumped trying to load the ndiswrapper module on demand for wlan0.
FC4 on a Pentium 4, kernel is  2.6.15-1.1833_FC4.

Tried ndiswrapper -m and putting alias wlan0 ndiswrapper into the
/etc/modprobe.conf, but it did not work:

options ndiswrapper if_name=wlan%d
alias wlan0 ndiswrapper

The 'ndiswrapper -m' adds a file to /etc/modprobe.d, but according to
the man pages, that one doesn't work if /etc/modprobe.conf is present
(which on my machine is present, as said). To remedy, I tried to move
modprobe.conf to modprobe.d, but that did not help.

I expected that just adding the options and alias to modprobe.conf would
help. I am doing a reinstall to a new hard disk on the same laptop,
after a disk crash. In the old setup the on-demand loading worked as far
as I can remember. The previous install was a while ago
so I cannot say for sure, but I don't remember having to fiddle with the
settings much further than just running 'ndiswrapper -m' after the
driver was installed.

For the record, loading ndiswrapper manually works, and I can use wlan0,
for instance with the help of NetworkManager. Also note that I use a
stock kernel, and not a 8k-stack variety, as my network card seems to
work fine without it. Could it have affected the autoloading?

Advice appreciated, or at least a pointer to how I can turn on some
debugging output to see what in fact is going on. Right now, no messages
appear in system logs that would point towards the solution.

Thanks,
f


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]