[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Addressing a SCSI film-scanner - SUCCESS!



On Wed, 2006-03-08 at 11:50 +0000, Anne Wilson wrote:
> Paul & Mogens, thanks to your encouragement I have successfully scanned!
> 
> There are two scsi connectors on the back of the scanner, and the 
> documentation does not make it clear which one I should use.  My memory was 
> that it only worked on one of them, but I couldn't remember which one.  I 
> changed the connection to the other one, and re-ran the rescan-scsi-bus.sh 
> script.  It found and correctly labelled the scanner on SCSI1, Channel 0, ID 
> 5, LUN 0 (obviously the tiny 5 on the setting had looked like a 3 to me).  At 
> that point I ran vuescan and it simply worked.  I did not need to apply the 
> patch at all.
> 
> According to the documentation the problem is almost certainly caused by a 
> delay in reporting after a scsi re-set.  It seems that there are now four 
> options for correcting this, two of which require a kernel recompile, so I'll 
> ignore them.
> 
> # Use the rescan-scsi-bus.sh script or manually use the scsi add-single-device 
> command to detect your device, whenever needed. You max want to put something 
> like (sleep 10; echo "scsi add-single-device C B T U" >/proc/scsi/scsi)&  to 
> your system startup scripts.
> 
> I think this is probably the simplest, and that the command would be "scsi 
> add-single-device 1 0 5 0" - do you agree?
> 
> # Prevent the tmscsim driver from resetting the SCSI bus on startup. Look at 
> README.tmscsim (it is included in the driver distribution and can be found 
> inside the kernel source tree in linux/drivers/scsi/README.tmscsim.) 
> [tmscsim=7,0,31,43]
> 
> Do you see any advantage in following the second way?
> 
> Anne

Anne,

I have had somewhat similar problems with a Umax 1200S SCSI scanner.  It
is supported by SANE, when it's detected by the SCSI driver.  However,
it is rarely detected.  I found that cycling the power on the scanner
prior to loading the SCSI module (Adaptec or BusLogic, in my case) seems
to make things work until the scanner goes into power saving mode, or
whatever turns off the light.  After that, the scanner no longer appears
to exist.  In my case the scanner is not detected during the BIOS scan,
unless I cycle the scanner's power prior to booting the computer.

Prior to Fedora it "just worked".  I've relocated residences a couple of
times and feel that something has happened to the scanner, as opposed to
a S/W problem.  I'll try exchanging the terminator and interface cable.
I cannot see why that would make a difference, since traditionally this
should just be a pass-thru.  But, SCSI interfacing has usually been
black magic anyway.  I haven't unpacked the SCSI voodoo talismans and
can't remember the incantations :-)

I've since bought a multi-function Brother (MFC-420CN) that was supposed
to have Linux support and indeed it does as long as you stick with a 32
bit distro, and can tolerate the lack of udev/hotplug support.  

Brother has GPL'd the SANE backend, but there seems to be a proprietary
library (no source code) that is only compiled for a 32 bit
architecture.  Brother afforded no help other than telling me to wait
for the 64 bit SANE driver.

Bob...





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]