[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Still gnawing on on FC4, CXO, GPS/topo maps, etc.



This may be a wine's nest -- or just maybe this time its a FC4
problem -- so I'll ask that part here. 

[Thumbnail background: in an attempt to use proprietary GPS/topo map
software under CXO, I've managed -- with a lot of help -- to do everything
but make the software interchange data with the GPS. It should, on a
serial port -- the way it does under XPPro/SP2. Better yet, I'd like it to
on a USB port -- serial ports are reportedly an ongoing problem with CXO,
and the two USB ports on the front of the PC are a lot handier for using
two GPSs than the only serial port on the back.]

So the current and probably last hope is to add symlinks into
.wine/dosdevices -- putting them in .cxo/dosdevices (one for each bottle)
succeeded afaict, but didn't help.

Trouble is, I have the following : 

btth localhost dosdevices]$ ls
c:  com1  com2  z:
[btth localhost dosdevices]$ file com1
com1: symbolic link to `/dev/ttyS0'
[btth localhost dosdevices]$ file com2
com2: broken symbolic link to `/dev/ttyUSB0'
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
[btth localhost dosdevices]$

NB: com2, but not com1, shows up on a red background on my screen, which
is what prompted me to try the file command. And I found confirmation --
of a sort : 

[root localhost ~]# ls /dev/ttyS*
/dev/ttyS0  /dev/ttyS1  /dev/ttyS2  /dev/ttyS3
[root localhost ~]# ls /dev/ttyU*
ls: /dev/ttyU*: No such file or directory
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
[root localhost ~]# 

Being a skeptical sort, I also tried ls /dev/tty* -- and sure enough,
it shows no /dev/ttyU-anything. Yet the machine has two USB ports right in
front. And when I do [root localhost ~]# ls /dev | grep tty I do get a
bottom line saying ttyUSB0 -- what in ....??

Incidentally, I also get 

[root localhost ~]# file /dev/ttyUSB0
/dev/ttyUSB0: character special (188/0)
[root localhost ~]#

which appears quite analogous to the results for tty, tty1, etc.

I plugged the adapter that goes between a serial cable and a USB port into
one, did /dev/ttyU* again, and got the same again, on both. So I tried it
again, with the serial cable and a live GPS on the adapter. Still none.

Do I need to add a couple of lines to /dev/? Can I simply command "nano -w
/dev" and type onto the bottom? Or What?? Why isn't the machine seeing its
own hardware, that's been there since I got it, months ago? Or why
is it seeing it one way, but not another??

-- 
Beartooth Staffwright, PhD, Neo-Redneck, Double Retiree,
Not Quite Clueless Linux Power User : Fedora Core 4 [etc]
I have precious (very precious) little idea where up is.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]