[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Brother 1440 printer on Fedora Core 4



On Tue, 2006-03-14 at 10:58 -0500, Neil Cherry wrote:
> Eric Beversluis wrote:
> > On Tue, 2006-03-14 at 10:34 -0500, Neil Cherry wrote:
> >> Eric Beversluis wrote:
> >>> On Tue, 2006-03-14 at 09:32 -0500, Neil Cherry wrote:
> >>>> Eric Beversluis wrote:
> >>>>> Help! I need my printer (Brother 1440). I've already spent two days
> >>>>> trying to get it up. I've learned a good bit about how printing works on
> >>>>> Linux, but haven't had success. (This printer always ran automatically
> >>>>> with my old Mandrake 10.1 install.)
> >>>>>
> >>>>> I've just installed Core 4 on a Sony PCG-SRX77. (I also installed
> >>>>> (server installation) on a Dell OptiPlex, but I haven't tried to get the
> >>>>> printer going there yet.)
> >>>>>
> >>>>> Brother has two drivers, one for lpd and one as a
> >>>>> "cupswrapper" (whatever that is). The lpd rpm needs to be installed
> >>>>> before the cupswrapper rpm. When I tried to install the lpd rpm I got
> >>>>> this error message:
> >>>>>
> >>>>>     /var/tmp/rpm-tmp.48389: line 2: /etc/init.d/lpd: No such file or 
> >>>>>        directory
> >>>>>     error: %post(hl1440lpr-1.1.2-1.i386) scriptlet failed, exit status 
> >>>>>       127
> >>>> Before installing the lpd driver you need to link lpd to cups in
> >>>> /etc/init.d. Then install the lpd driver. Then install the
> >>>> cups driver.
> >>> But as nearly as I can tell, lpd isn't there anywhere (it doesn't show
> >>> up in 'ps -e' either. I'm confused.
> >> Read the directions on the Brother page. That what they state, I did
> >> it then I removed the link afterwards. Then I loaded up the cups
> >> driver. I don't know why but that's the way it worked. I'm using
> >> a HL2070N.
> > 
> > OK. I'll try that. It seems strange to link an non-running and
> > apparently nonexisting daemon to something. But if it worked for you I'm
> > game.  I'll let you know what happens.
> 
> I think it stops the rpm from running the post install script. The
> problem I had was selecting the correct URI for the networked
> printer. I finally got http://printer/ipp/port1 to work and not
> split out a billion blank pages.

It seems to have worked--anyway I've had a test page print out OK. We'll
see what happens when I reboot (I had it printing once before--don't
know how--and rebooting screwed things up). Apparently the instruction
on page
http://solutions.brother.com/linux/sol/printer/linux/lpr_drivers.html

"To use this driver, you must ensure that the LPR printing system is
installed and running on your Linux distribution."

was a red herring.
Thanks for the help
> 
> -- 
> Linux Home Automation         Neil Cherry       ncherry linuxha com
> http://www.linuxha.com/                         Main site
> http://linuxha.blogspot.com/                    My HA Blog
> http://home.comcast.net/~ncherry/               Backup site
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]