[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Follow on to tough problem on compiling



Hello, list.

Well, after some detective work, I've managed to track all my problems
down to:

libbonoboui
libgnomeui

Those two libraries had 2 versions installed: the 32-bit and the 64-bit,
and they were even different versions. So I removed (rpm -e) all the
32-bits ones, and then I tried to install one of the programs that
started all this problem (rpm -ivh). I got "Failed dependencies:
libbonoboui-2.so.0 and libgnomeui-2.so.0 are needed". So I reinstalled
both packages, but in 64-bit versions and matching the ones installed
(rpm -ivh --replacepkgs), and now I have just one version of each, and
the correct one (64-bits). The problem is that I still get the "Failed
dependencies" on the package installation. I tried with symbolic links
from /usr/lib to the real location (/usr/lib64), to no avail. I also
tried (removing links first) to run ldconfig, to no avail also.

Any other ideas of how can I "trick" the program to actually see both
(already) installed libraries?

I know that the "Microsoft approach" (reinstall operating system, all
apps, and all the rest) would work, but I prefer to think that Linux is
smarter than that, isn't it?

Thanks to all in advance,

-- 
Mariano López Reta <mlreta alternativagratis com>
Tortuguitas, Buenos Aires, Argentina

Registered Linux user #412032
Count yourself at http://counter.li.org



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]