[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: PHP as DSO



Myth User wrote:
I'm looking to install a new system and want to make sure that PHP is installed as a DSO. Recently I used the gui installer and simply selected httpd(apache) and when it installed I had php support but no support for xslt or sablotron. When I tried to rebuild php I got errors saying that I would have to rebuild apache as well. As you can tell I am sorta new to this so please help me if you can.


It's been awhile since I built apache or php but I don't think you actually have to rebuild apache; you just need to let php know about the apache that will be running the php module.

If you are running apache-1.3.x include this in the php ./configure
    --with-apxs=/usr/sbin/apxs

If you are running apache-2.x include this in the php ./configure
    --with-apxs2=/usr/sbin/apxs

Hope that is helpful,
Mike Wright :m)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]