[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: hosed RPM



Mark Haney wrote:
Andy Green wrote:
Mark Haney wrote:
Okay, my very first hosed rpmdb.  I tried rebuilddb, no go.  I tried
initdb /then/ rebuilddb no go.  Any other ideas?  Fortunately, this
isn't a production system (yet) so I can blow it away if I need to.  I
was running up2date on the box from ssh and for some reason sshd died in
the middle of it.

up2date :-O  Use yum.

Check your /var/log/messages for, eg, memory-related problems that
provoked things to blow up in the first place.

What exactly are the symptoms when you try, for example,

rpm -qa

-Andy

rpm -qa gives me a package list like it should. This is what I get when I up2date:

RPM error.  The message was:
Could not determine what version of Red Hat Linux you are running.
If you get this error, try running

               rpm --rebuilddb





Maybe the redhat-release or fedora-release package was missing / corrupted. I believe this is where the version information is acquired.

Just to note that up2date should not be included with FC5. The equivalent (but better, in my view) program is called pup (Or under the applications > System Tools menu called Software Updater.

I used up2date for a long time and used it up until I upgraded to the test for FC5 and apapted to the program without missing up2date.

RHEL or FC2, I don't know how those versions are. It does not sound like the whole rhdb is broken, just that rpm has no idea what versino you are running. The release packages was my first thought when reading your question.

Jim

--
Fresco's Discovery:
	If you knew what you were doing you'd probably be bored.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]