[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Yum proxy problem



Hi
I installed FC4 and tried to configure yum to work. I am behind a proxy server which requires authentication.
My /etc/yum.conf file is

[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
retries=20
obsoletes=1
gpgcheck=0

# The proxy server - proxy server:port number
proxy=http://vsnlproxy.iitk.ac.in:3128/
# The account details for yum connections
proxy_username=spsingh
proxy_password=password

I had a password with % in it. When trying yum update I got HTTP Error 407 ie proxy authentication required. When i tried to search for the problem on net, I came across this
http://beau.org/pipermail/whitebox-users/2004-March/000781.html
which shows that the guy had problem connecting because of special character which yum could not understand/encrypt.
I did the same.Changed my password so that it had alphanumeric only and yum worked!!!!!
Wget, apt (on ubuntu5.10 and FC4) used to work with old password.
Is this a problem with yum. Can someone please test it out!! Also can I submit it as bug?

I had same problem while installing gentoo previous month. it did not emerge and finally I gave up the installation. Can someone please test this and let me know. i will appreciate it. My email id is sumeetpalsingh gmail com

Thanks in Advance.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]