[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Yum update: Missing Dependency: libopenobex-1.0.so.1()?



On Sun, 2006-03-19 at 15:12 +0200, Gilboa Davara wrote:
> Hello all,
> 
> I'm trying update my FC4/64 machine I'm getting a weird yum error.
> Yum fails to a missing library (libopenobex-1.0.so.1()(64bit)) which
> exists and installed... 
> Any ideas?
> 
> [root gilboa-home-dev lib64]# yum update
> Setting up Update Process
> Setting up repositories
> Reading repository metadata in from local files
> Resolving Dependencies
> --> Populating transaction set with selected packages. Please wait.
> ---> Package freeciv.x86_64 0:2.0.8-1.fc4 set to be updated
> ---> Package shadow-utils.x86_64 2:4.0.12-8.FC4 set to be updated
> ---> Package gpgme-devel.x86_64 0:1.1.2-3.fc4 set to be updated
> ---> Package slib.noarch 0:3a1-5.fc4 set to be updated
> ---> Package net-tools.x86_64 0:1.60-52.fc4.2 set to be updated
> ---> Package k3b-devel.x86_64 0:0.12.14-0.1.fc4.kde set to be updated
> ---> Package samba.x86_64 0:3.0.21c-0.1.fc4.kde set to be updated
> ---> Package db4-utils.x86_64 0:4.3.27-5.fc4 set to be updated
> ---> Package k3b-extras.x86_64 0:0.12.14-0.1.fc4.kde set to be updated
> ---> Package openobex.x86_64 0:1.1-1.fc4 set to be updated
> ---> Package tcsh.x86_64 0:6.14-1.fc4.2 set to be updated
> ---> Package db4-devel.x86_64 0:4.3.27-5.fc4 set to be updated
> ---> Package libtunepimp-devel.x86_64 0:0.4.2-1.fc4 set to be updated
> ---> Package db4.i386 0:4.3.27-5.fc4 set to be updated
> ---> Package kdetoys.x86_64 7:3.5.1-3.fc4 set to be updated
> ---> Package k3b.x86_64 0:0.12.14-0.1.fc4.kde set to be updated
> ---> Package samba-common.x86_64 0:3.0.21c-0.1.fc4.kde set to be updated
> ---> Package bash-completion.noarch 0:20060301-1.fc4 set to be updated
> ---> Package redhat-artwork.i386 0:0.124-2.0.fc4.kde set to be updated
> ---> Package redhat-artwork.x86_64 0:0.124-2.0.fc4.kde set to be updated
> ---> Package gnupg.x86_64 0:1.4.2.2-1 set to be updated
> ---> Package libtunepimp.x86_64 0:0.4.2-1.fc4 set to be updated
> ---> Package db4.x86_64 0:4.3.27-5.fc4 set to be updated
> ---> Package samba-client.x86_64 0:3.0.21c-0.1.fc4.kde set to be updated
> ---> Package gpgme.x86_64 0:1.1.2-3.fc4 set to be updated
> --> Running transaction check
> --> Processing Dependency: libopenobex-1.0.so.1()(64bit) for package:
> gnome-bluetooth
> --> Processing Dependency: libopenobex-1.0.so.1()(64bit) for package:
> libbtctl
> --> Finished Dependency Resolution
> Error: Missing Dependency: libopenobex-1.0.so.1()(64bit) is needed by
> package gnome-bluetooth
> Error: Missing Dependency: libopenobex-1.0.so.1()(64bit) is needed by
> package libbtctl
> 
updating openobex is trying to update/remove libopenobex-1.0.so.1 but
gnome-bluetooth and libbtctl need that file.

I also note that gnome-bluetooth and libbtctl are not in the list being
updated.  It may be a delay in the mirror updates or it may be an error
in dependencies.

One way would be to remove gnome-bluetooth and libbtctl then do the
update, and if those are needed then reinstall them.

> [root gilboa-home-dev lib64]# locate libopenobex-1.0.so.1
> /usr/lib64/libopenobex-1.0.so.1.0.0
> /usr/lib64/libopenobex-1.0.so.1
> /usr/lib/libopenobex-1.0.so.1.0.0
> /usr/lib/libopenobex-1.0.so.1
> 
> [root gilboa-home-dev lib64]# rpm
> -qf /usr/lib64/libopenobex-1.0.so.1.0.0
> openobex-1.0.1-3.0.FC4.1.x86_64
> 
> Gilboa
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]