[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum update FC4==>FC5 kudzu and initscripts dependence problem



yonas abraham wrote:
Hi,

In my laptop I tried to use yum to bring my FC4 system to FC5. I downloaded the fedora-release rpm fron the FC5 tree and installed/updated it. It created some *repo.rpmsave. After reviewing the diff, I have copied the respective file to their *.repo file.

I did yum update

and after a lot of download/test yum comes up with the two errors

Error: Package initscripts needs kernel < 2.6.12, this is not available
Error: Package kudzu needs kernel < 2.6.13, this is not available

I taught FC5 comes with kerner 2.6.15 and why would these two packages depend on old kernels?

any help?



You probably need to do an rpm -q kernel followed by an
rpm -e kernel-2.6.12<whatever> and remove the 2.6.12 kernel versions.

There was a change where these older kernels being installed on the system will give you these errors.

You might try yum update yum followed by yum update kernel first. This might get rid of the older kernels. The newer version of yum keeps the running kernel and installs the later kernel. this should get rid of the many kernels that FC4 left behind on your system.

Check the fedora-test-list archives for clearer discussions and explanations.

Jim

--
I'll see you... on the dark side of the moon...
		-- Pink Floyd


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]