[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problems with yum after update FC4->FC5



On Wed, 2006-03-22 at 08:26 +0100, Joachim Backes [RHRK] wrote:
> Hi,
> 
> after updating from FC4 to FC5, I have problems to update my system:
> 
> yum update
> Setting up Update Process
> Setting up repositories
> core                                                                 [1/3]
> Cannot find a valid baseurl for repo: core
> Error: Cannot find a valid baseurl for repo: core
> 
> Addtitionally, I removed all yum files/dirs in /etc and reinstalled yum, but nothing helped.
> 
> Always getting the same error msg.
> 
> /etc/yum.conf:
> #======================================================
> [main]
> cachedir=/var/cache/yum
> debuglevel=2
> logfile=/var/log/yum.log
> pkgpolicy=newest
> distroverpkg=redhat-release
> tolerant=1
> exactarch=1
> retries=20
> obsoletes=1
> gpgcheck=1
> exclude=kernel*
> #========================================================
> 
> 
This is not the yum.conf I got with my FC5 install.
You did an update, so it seems the likely cause is that yum may have
created a .rpmnew file for your yum.conf instead of replacing it.
Possibly the same happened with files in /etc/yum.repos.d .  You need
the new yum.conf and the new /etc/yum.repos.d/*.repo files to use yum on
the new distribution.

You may want to do a download of the yum rpm file (or use the one on
your install CD/DVD) then do a "yum erase yum" or an "rpm -e yum".

After that completes do an rpm reinstall of yum to get all the new
yum.conf and .repo files


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]