[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Quibbles with suspend-to-ram



William John Murray wrote:
  Hello all,
       I have suspend-to-ram working very nicely under FC5, with two
fixes to my Latitude D610:
   * vga=normal as boot parameter
   * /sbin/service network  stop/start on suspending

That sounds ghastly. I run Kismet on my laptop, and suspend/resume works fine, on SUSE 10.0, where networking generally is more difficult than it should be.

Restarting networking with kismet running seems likely to cause something to fail.


But there are still two wrinkles:
   * Evolution hangs after a suspend. Maybe this is because of my cruel
network stop?

Possibully. I'd guess network timeouts are causing grief.

Mind you, the usual reason I suspend/resume is to transport the laptop between home and work, and when that happens the network does need to be reset.



   * Sometimes on resume it immediately suspends/tries to suspend again.
In /var/log/messages I see one occasion where I closed the lid,
removed the power supply, put the machine in my bag. On resume it
somehow finds two suspend instructions: One from closing the lid, the
other from disconnecting power with the lid closed. On other occasions I think the on wakeup it finds it has been more
than my timeout without mains power and suspends again.
   Is there something which could be done to trap these?


I run FC3 on another laptop, and it suspends, resumes and then shutsdown. It sounds like a variation of my problem.


--

Cheers
John

-- spambait
1aaaaaaa computerdatasafe com au  Z1aaaaaaa computerdatasafe com au
Tourist pics http://portgeographe.environmentaldisasters.cds.merseine.nu/

do not reply off-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]