[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: upgrading redhat 8.0 to Fedora Core 1 difficulties



Am Do, den 23.03.2006 schrieb Noah um 16:37:

> I am having some difficulties upgrading redhat 8.0 to FC1.  It appears some
> libraries are not being located.  one of hte libraries is libtk.so.0 but I
> have tk loaded on the machine.  Also I rebooted and it is still claiming to be
> a redhat 8.0 machine (see below).  Is there another step I need to do?  Why
> are these libraries not present?

Newer versions of tcl / tk libs are coming with FC1. libcom_err.so.3 is
pre FC1 only.

> --- instructions for yum upgrade ----
> 
> http://www.brandonhutchinson.com/Upgrading_Red_Hat_Linux_with_yum.html
> 
> ---- yum stuff and dmesg --
> 
> 
> # yum upgrade
> Gathering header information file(s) from server(s)
> Server: Fedora Core 1 - i386 - Base
> Server: Fedora Core 1 - i386 - Released Updates
> Finding updated packages
> Downloading needed headers
> Finding obsoleted packages
> Resolving dependencies
> .package ical needs libtk.so.0 (not provided)
> package ical needs libtk.so.0 (not provided)
> package python2-tkinter needs libtk.so.0 (not provided)
> package python2-tkinter needs libtk.so.0 (not provided)
> package ical needs libtk.so.0 (not provided)
> package ical needs libtk.so.0 (not provided)
> package python2-tkinter needs libtk.so.0 (not provided)
> package python2-tkinter needs libtk.so.0 (not provided)
> package apt needs librpm-4.1.so (not provided)
> package apt needs librpmdb-4.1.so (not provided)
> package apt needs librpmio-4.1.so (not provided)
> package python2-tkinter needs python2 = 2.2.1-1 (not provided)
> package apt needs libelf.so.0 (not provided)
> package ical needs libtcl.so.0 (not provided)
> package ical needs libtcl.so.0 (not provided)
> package python2-tkinter needs libtcl.so.0 (not provided)
> package python2-tkinter needs libtcl.so.0 (not provided)
> package ical needs libtcl.so.0 (not provided)
> package ical needs libtcl.so.0 (not provided)
> package python2-tkinter needs libtcl.so.0 (not provided)
> package python2-tkinter needs libtcl.so.0 (not provided)
> package gq needs libcom_err.so.3 (not provided)
> package pine needs libcom_err.so.3 (not provided)

rpm -e ical python2-tkinter apt gq pine

Reinstall programs you need after the successful upgrade.

Anyway, I recommend a fresh install of a non-legacy Fedora Core release
(FC 4 or FC5).

Alexander


-- 
Alexander Dalloz | Enger, Germany | GPG http://pgp.mit.edu 0xB366A773
legal statement: http://www.uni-x.org/legal.html
Fedora Core 2 GNU/Linux on Athlon with kernel 2.6.11-1.35_FC2smp 
Serendipity 21:29:20 up 9 days, 23:17, load average: 0.44, 0.35, 0.24 

Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]