[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC4->5 upgrade httpd (apache) problem - solved



Alexander Dalloz wrote:
Am Sa, den 25.03.2006 schrieb Don Russell um 20:06:

Sure enough, there was a httpd.conf.rpmnew file. I checked to see if there were any changes in httpd.conf that I needed to carry over, and no, I hadn't made any changes.

If you customized the default httpd.conf from FC4 in no way, then you
can use the httpd.conf from FC5 the same way. No custom settings would
have to be transferred.

I renamed the httpd.conf file as httpd.conf-old-fc4
then renamed httpd.conf.rpmnew as httpd.conf

Trying to start httpd resulted in the same error:

[root boris conf]# service httpd start
Starting httpd: httpd: Syntax error on line 147 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/mod_access.so into server: /etc/httpd/modules/mod_access.so: cannot open shared object file: No such file or directory
                                                           [FAILED]


That can't be with the httpd.conf shipping with Apache2 2.2.0-5.12 from
FC5.

Since that solve anything, I renamed the fies back the way they were.

I don't have a lot of stuff on the web server... I'm thinking of just backing up my individual pages and cgi scripts, removing httpd altogether and then 'yum install httpd'.

But that seems extreme... the only thing wrong seems to be this mod_access.so file can't be found? hmmm, so what happened to it? It's referred to in both (fc4/5) httpd.conf files...

Don

You would have looked closer. mod_access isn't an Apache2 2.2 module,
while it was in Apache2 2.0. Please read the page Paul mentioned:

http://httpd.apache.org/docs/2.2/upgrading.html
   mod_access has been renamed to mod_authz_host

Alexander


Yes, I was just reading that information, and went back to the directory that has the httpd.conf file...

I noticed that the two files I compared both had comments at the top referring me to ... doc.2.0 ... on further inspection of the directory contents, there was also a httpd.conf.bak file... THAT one had a comment referring to 2.2... Inspection of THAT file showed the "greatly simplified" config file...

I renamed httpd.conf.bak to httpd.conf and all is well.

Thanks for the tips.. :-)

Don


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]