[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: missing deps for NVU



Paul Howarth wrote:
> On Sat, 2006-03-25 at 08:19 +0100, LarryT wrote:
>> Hi all :)
>> Trying to install nvu, for fc4 rhel4 .... - :-/)
>> http://www.nvu.com/download.html
>> specialy this one :
>> http://www.nvu.com/download/linux/1.0/nvu-1.0-RedHat_and_Fedora/nvu-1.0-1_nokde.rhel4.fs.i386.rpm
>> But get failed deps message :
>>> [root Fopadix-fc5 downloads]# rpm -ivh nvu-1.0-1_nokde.rhel4.fs.i386.rpm
>>> error: Failed dependencies:
>>>         xorg-x11-deprecated-libs is needed by nvu-1.0-1_nokde.rhel4.fs.i386
>> any way to resolve this problem , please ?
>>
>> PS i know fc4 or rhel4 is not fc5 :-p ; but ,... never know :)
> 
> This is a poorly-made RPM, with an explicit library package name
> dependency. The libraries you need are almost certainly available in FC5
> but in differently-named packages. The necessary library dependencies
> should be automatically generated at package build time and the
> xorg-x11-deprecated-libs dependency is redundant (and in this case,
> harmful).
> 
> If that's the *only* dependency that rpm complains about, you'll
> probably find that it works if you install it using the "--nodeps"
> option to RPM. But it would be better to get the packager to fix the
> package so that it doesn't have this dependency in the first place.
> 
> Paul.
> 

I found that the nvu rpm (nvu-1.0-0.1.i386.rpm) that I found on
rpmfind.net installed without problem.  It's different from the one
available from nvu.com which I also couldn't install.

-- 
Sjoerd Mullender

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]