[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: azureus and java sun



Le lundi 27 mars 2006 à 13:51 -0800, Kam Leo a écrit :
> On 3/27/06, Adam Antoniak <antoniak wyszkow mm pl> wrote:
> > I get similar error:
> >
> > ~/.azureus/app/plugins /usr/bin
> > /usr/bin
> > Exception in thread "main" java.lang.UnsatisfiedLinkError: no
> > swt-pi-gtk-3139 in  java.library.path
> >         at java.lang.ClassLoader.loadLibrary(Unknown Source)
> >         at java.lang.Runtime.loadLibrary0(Unknown Source)
> >         at java.lang.System.loadLibrary(Unknown Source)
> >         at
> > org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
> >         at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:19)
> >         at
> > org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
> >         at
> > org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
> >         at org.eclipse.swt.widgets.Display.<clinit>(Display.java:122)
> >         at
> > org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(SWTThread.java:7 5)
> >         at
> > org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(SWTThrea
> > d.java:58)
> >         at
> > org.gudy.azureus2.ui.swt.mainwindow.Initializer.<init>(Initializer.ja
> > va:109)
> >         at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:127)
> >         at org.gudy.azureus2.ui.swt.Main.main(Main.java:142)
> >
> > My system is x86_64
> >
> > Adam
> >
> > Dnia 27-03-2006, pon o godzinie 23:27 +0200, Eric Tanguy napisał(a):
> > > Le lundi 27 mars 2006 à 12:05 -0500, Andrew Overholt a écrit :
> > > > * Eric Tanguy <eric tanguy univ-nantes fr> [2006-03-21 09:24]:
> > > > > since i installed java sun 1.5 in fedora core 5 using java source from
> > > > > jpackage, azureus makes errors at startup :
> > > > > Exception in thread "main" java.lang.UnsatisfiedLinkError: no
> > > > > swt-pi-gtk-3139 in java.library.path
> > > >
> > > > Are you mixing x86 and x86_64?  The most common cause of this that I know
> > > > of is attempting to run the 64-bit JNI bits on a 32-bit JVM.
> > > >
> > > > Andrew
> > > >
> > > No all my system is x86.
> > > Eric
> > >
> > >
> 
> Check your environment settings. Is Sun Java at the beginning of PATH
> or tacked on at the end? From CLI  do a "java -version"?  If not Sun's
> java fix your links or go whole hog and download jpackage.org's
> instructions for building "nonfree" java rpms that work with
> alternatives.
> 
PATH=/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/tanguy/bin:/sbin

java -version
java version "1.5.0_06"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
Java HotSpot(TM) Client VM (build 1.5.0_06-b05, mixed mode, sharing)

$ rpm -qa | grep java-1.5.0
java-1.5.0-sun-jdbc-1.5.0.06-1jpp
java-1.5.0-sun-alsa-1.5.0.06-1jpp
java-1.5.0-sun-fonts-1.5.0.06-1jpp
java-1.5.0-sun-plugin-1.5.0.06-1jpp
java-1.5.0-sun-1.5.0.06-1jpp
java-1.5.0-sun-demo-1.5.0.06-1jpp
java-1.5.0-sun-devel-1.5.0.06-1jpp
java-1.5.0-sun-src-1.5.0.06-1jpp

built from jpackage.

and it still not work.

I uninstalled azureus from extras and installed it manually from azureus
website and it works fine. So the azureus from extras is built to work
with java built in FC-5 but seems to not work when java-sun is
installed.

Eric



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]