[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rebuilding X from failed FC4 -> FC5 upgrade



Jim Cornette wrote:
Mark Haney wrote:
I upgraded one of my machines to FC5 from 4 the other night and everything went smoothly except on reboot. Now X doesn't work. It appears that Xorg didn't completely install. I've tried everything I know, but can't get it completely uninstalled. It tells me xorg-x11-xdm is not installed, but when querying rpm I get the correct version from FC5 (1.0.something). Any ideas on how to completely blow X away and re-install?


Probably the best way to correct the xorg problem is to use the install media if DVD and use rpm -Uvh --replacefiles --replacepkgs xorg-x11*.rpm which should install all xorg-x11 packages and overwrite the files previously installed.

Two questions before you attempt to remove and replace X:

- Did you try to start X in runlevel 3 using startx?
Yes I tried that and I got some odd error about xinit not being in the environment vars? (I'm not at the system so I can't say for certain.) It seems like there's not X server installed based on the error message.

- Did you try to run system-config-display --reconfig in runlevel 3 as root to try to reconfigure X?
No, I didn't try this, but I certainly will when I get home. Thanks for the suggestions.


Jim



--
Interdum feror cupidine partium magnarum Europae vincendarum

Mark Haney
Sr. Systems Administrator
ERC Broadband
(828) 350-2415


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]