[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC5 nforce4 sata initrd problems [for geeks??]



Wieslaw Kierbedz wrote:

Hi

For some reasons I'm looking for easy to install and easy configurable
linux.
I remember that FC is really user friendly and against some of other
distros does not destroy hand made configs.
Installation passed successfully.
At boot I've got kernel panic.

...
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!


Then:
Fresh FC5 on /dev/sda3 - reiserfs.
/dev/sda3            /                       reiserfs defaults        1 1
bootloader: gentoo's (what the different ;)) lilo in sda mbr.
I had similar problems using reiserfs. Ultimately, the problem was with the "mount by label" system. Check your fstab. You will probably have and entry like LABEL=/ rather than /dev/sda3. I assume (I use grub, not lilo, so I don't know for sure) that there is a similar entry in the lilo config. Use the dvd rescue to change them both from LABEL=/ to /dev/sda3 and reboot. That should fix the problem.
Dan.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]