[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: lsusb





On 29 Mar 2006 17:27:48 +0200, Ingemar Nilsson <init pdc kth se> wrote:
"Tod Merley" <todbot88 gmail com> writes:

> I do not have FC5 up yet.  I first tried a "locate lsusb" after recently
> running "updatedb" as root and found nothing.  I did a Places > Search For
> Files and in the "Look in Folder" chose the CD.  I searched for "usb" and
> found usbutils-1.0.13.i386.rpm on FC4 disk 4.  After installation and doing
> another "updatedb" I located /sbin/lsusb and its manual gz file (so "man
> lsusb" now works).  I also did an "lsusb" in google which is great for info.

This sounds like a really awkward way. There are other ways:

1) If you have an rpm, like the usbutils rpm you mentioned, you can run

rpm -qlp usbutils-1.0.13.i386.rpm

which will list all files that will be installed by this rpm. Remember,
qlp = Query List Packagefile. If the package is already installed, remove
the p, getting -ql.

2) The easiest way is to use yum:

yum provides lsusb

which will list the packages that contain any file that has lsusb in the
name. This means that the above command will give both the program file and
the man page:

usbutils.i386                            0.70-1.1               core
Matched from:
/sbin/lsusb
/usr/share/man/man8/lsusb.8.gz

The output may differ slightly on FC5, since I ran this on FC4.

Regards
Ingemar

--
fedora-list mailing list
fedora-list redhat com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Hi Ingemar!
 
Thanks for the info!
 
FC5 defaults to looking to the internet for adding or removing programs.  Knowing yum better is something I am thankful for.  Thanks again!
 
Sometimes I wonder, however, if it would be better to use a time frozen "snapshot" of all the software rather than the "moving target" of the most recent.  I see a lot of mail here and elseware where "I updated and something broke" is the cry!
 
With gratitude!
 
Tod
 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]