[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Problem with mounting hard disk after FC5 installation



At 6:25 PM -0500 5/3/06, Brian Hanks wrote:

>[I wrote}:
>> At 1:31 PM -0500 5/3/06, bhanks crackedweasel org wrote:
>>>I've run into the same problem where I have an old hard drive with an
>>>EXT3 partition what cannot be mounted following the FC5 install.  Note
>>>that this same partition will mount fine using Knoppix or older versions
>>>of Fedora.
>>>
>>>I recently installed FC5 on my main machine.  This machine used to run
>>>FC4, but this was not an install.  I dropped two new 160GB SATA drives
>>>into the machine and performed a clean install.  Prior to the install I
>>>backed all of my important data files up to an old 40GB IDE drive.  I am
>>>using both software RAID and LVM on the new install, but everything went
>>>smoothly with that.  The only issue is that the EXT3 partition on the old
>>>40GB drive cannot be mounted.  It produces and error as follows:
>>>
  ["mount: /dev/hde1 is not a valid block device"]
>>>
>>>This IDE drive is connected to an HPT302 IDE controller card, but the
>>>last time I had problems with a card of this type was several years ago.
>>>
>>>I've been down the SE Linux road, and that doesn't seem to be the issue.
>>>
>>>Any other ideas?
>>
>> Hmm, when I try to screw around with non-existent or non-block devices I
>> get different error messages, so mount has a specific complaint about your
>> /dev/hde1.  What happens if you try to dd from it?
>>
>>     dd if=/dev/hde1 of=/dev/null count=100000

>I ran partprobe on /dev/hde and that changed the error message to the
>following:  mount: /dev/hde1 already mounted or /mnt/sata_files busy
>
>Unfortunately, it stil won't mount, unmount, or anything else.
>
>Per your suggestion, I ran the dd command it it ran fine.  No errors - all
>data copied.

OK.  Does it show up in /proc/mounts, by any chance?  (I'm presently
feeling distrustful of mount.)  I'm not sure what partprobe has done -- why
anything changed.  Does "fdisk -l /dev/hde" (dash ell) output look sane?
____________________________________________________________________
TonyN.:'                       <mailto:tonynelson georgeanelson com>
      '                              <http://www.georgeanelson.com/>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]