[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Brother MFC-5440CN printer on FC3 and FC5

On Thu, 2006-05-04 at 15:09 -0500, Brian Hanks wrote: 
> > Brian Hanks wrote:
> >>
> >>> Hi,
> >>>
> >>> I am trying to buy * Brother MFC-5440CN printer for my home office and
> >>> I
> >>> was reading several reviews. but can't find specific to Fedora in
> >>> general FC3 and FC5 in particular.
> >>>
> >>> It would help me if some one who tried this model under FC3 or FC5 to
> >>> share their success steps or frailer in making the printer a Networked
> >>> printer.
> >>>
> >>> Both my machines   (FC3 and FC5) are uptodated
> >>> thanks
> >>> *
> >>>
> >>> --
> >>> Yonas Abraham, PhD
> >>> Registered Linux user number 407343               http://counter.li.org
> >>>
> >>>
> >>
> >> I have a Brother MFC-8840DN that I've used as a networked priter with
> >> FC3
> >> & FC5.  No problems at all.
> >>
> >>
> >> -- Brian
> >>
> >>
> > did you follow the same steps as it is on the brothers Linux page?
> >
> > from what I understood, I should be able to
> > 1)rpm -ivh MFC5440CNlpr-1.0.2-1.i386.rpm
> > 2)rpm -ivh cupswrapperMFC5440CN-1.0.0-1.i386.rpm
> >
> > and the use the SYSTEM-->Administration-->Printing and add new printer
> > as JetDirect and use the default Port (9100) and use the Printers IP.
> >
> > or is you use a different method?
> >
> > THanks
> >
> > --
> > Yonas Abraham, PhD
> > Registered Linux user number 407343               http://counter.li.org
> >
> >
> I have used the Brother drivers before.  Originally, I had no luck with
> them, then a while later I got them working.
> Currently, I'm just using one of the built-in printer drivers configured
> for JetDirect mode (printer_ip:9100).  There wasn't an exact driver match
> so I just went through the built-in Brother drivers and found one with a
> similar model number and a matching resolution.  If the test page works,
> I've found that it'll work for almost anything.  I've only run into issues
> once or twice in the past several years and those were easily fixed by
> selecting a different driver from the list.
> That said, I've been meaning to circle back and try the Brother supplied
> drivers again.  I just haven't done it yet.
> -- Brian

I have followed your procedure, but I tried all the similar models with
the default drivers didn't work. 

I downloaded and installed the rpm packages for LPR and CUPS from the
brother website and installed it in my FC5 machine.

   a) I added a new printer from System-->Admin-->printing but I still
can't see the new driver. But I can see the printer as a browseble  but
any test page failed.
  b) I opened localhost:631-->manege printers. after I put my root
password, I see the printer automatically listed and the one I added in
above. For the automatically available one the  Device URI:
usb:/dev/usb/lp0. When I try to modify it, I got error.  So I just
modified the one I added above to be an LPD Unix type and i put Device
URI: lpd:// and I can see the exact model
listed. where is the IP of the printer and BRN_A17303 is
the queue name (I got this from my router DHCP status page). The test
page worked and I printed a text page from gedit. 

I went back to System-->Admin-->printing, and I still can't see the
exact model. why is this? I taught system-config-printing is a gui for
CUPS, if so why can't I see the driver for my model though the GUI while
It is possible to see it from localhost:631?

I used to remember for redHat used to discourage ppl from using
localhost:631 or edit the printconf file. The reason was that it would
be overwritten by the  system-config-printing? did that change in

Next stop, to make the scanner and fax to work.
Registered Linux user number 407343

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]