[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: umounting detatchable media in FC5

On Fri, 05 May 2006 11:41:59 -0400
Glenn Lawyer <d g lawyer medisin uio no> wrote:

> Hi,
> A  USB issue with FC5 (fresh install on a 64 bit AMD). Logged in as a 
> regular user, using the KDE desktop. Connect a USB drive. It
> automounts and I get the nice icon on the desktop. From the icon I
> can "safely remove" or (after "safely removing") "mount" the drive.
> Can't do either from the command line. umount tells me I'm not root,
> and mount fails because the device isn't listed anywhere I know of.
> Yes, I could probably spend 4 hours reading 
> http://www.reactivated.net/writing_udev_rules.html, and then another 
> hour reading up on sysf, but geez, it shouldn't take all day and
> mastery of two subsystems to learn how to (u)mount a drive from the
> command line, especially when the disto includes GUI commands for the
> same action!
> Can you kindly give the ½ hour tutorial version? Here's my very vague 
> and probably wrong outline, posed as questions:
> do I add a line for each detachable media to my fstab file? Could
> you give me an example line for a thumbdrive that automounts as 
> "/media/CORSAIR"?
> Could you give me an example udev rule that would put this drive
> where fstab says it should go?

Hello, Glenn
I can't give you an example of a udev rule.  But I can tell you that I
use the KDE desktop as well, and that I had the same problem that you
are having now when I installed FC5.  What I have done is to add the
following lines to my /etc/fstab:
   /dev/scd0	/media/cdrecorder	udf,iso9660	auto,user,kudzu,exec,ro 0 0
#/dev/scd1	/media/cdrecorder	udf,iso9660	auto,user,kudzu,exec,ro 0 0
   /dev/hdd	/media/cdrom		udf,iso9660 	auto,user,kudzu,exec,ro 0 0
#/dev/sdb1	/media/usbdisk	auto			auto,user 0 0
   /dev/sda1	/media/usbdisk	auto			auto,user 0 0

You can ignore the lines that are commented out.  For some reason, I
have an additional issue where /dev/scd0 will become /dev/scd1,
and /dev/sda1 will become /dev/sdb1 (but this hasn't happened for a
while :))  (My cdrecorder of the external USB2.0 variety.)

In response to your problem, I just made it even more user-friendly for
myself.  Do as follows:
1. Put lines in /etc/fstab for any devices that you may want to mount
as a regular user, using the examples from my own /etc/fstab
2. In your "~/.kde/Autostart" directory, create a symlink to
3. In your "~/.bashrc" put a line like this:
alias autorun="/usr/bin/autorun -d"
This will force "autorun" to run as a daemon after you login to KDE.
4. Log out, and then log back in.

I just tried logging out and then logging back in WITH a data CDROM in
my cdrecorder.  When I logged in, that CDROM mounted with no
interference from me :)  I then opened up a terminal and ran
"umount /media/cdrecorder" as a regular user.  Worked perfectly.  Word
of caution, though: I left the CDROM in the drive as I continued typing
this, and it remounted itself :)

For whatever reason, my flash drive does not automount on login.  Not a
huge deal, since I can now run "mount /media/usbdisk" as a regular
user.  Also, using the MountMan feature on the Krusader file manager:
That works great as well (again, as a regular user)

If this does not work as seamlessly for you as it does for me, let me
know and maybe I can help you further.

Steven P. Ulrick

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]