[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

wlan0 device not present FC5 x86_64

Unable to get ndiswrapper to work on 64 bit kernel.  Works a treat on
smp kernels.

lspci shows hardware present.
	05:06.0 Network controller: RaLink Ralink RT2500 802.11G
Cardbus/mini-PCI (rev 01)

lsmod shows ndiswrapper.ko loaded.

ndiswrapper shows hardware present:	
[keepertoad office ~]$ ndiswrapper -l
Installed drivers:
rt2500          driver installed, hardware present

Driver used is w2k/xp 32 bit.  WinXP 64 bit driver results in hard lock
requiring hardware reset.

service network restart responds with "wlan0 not present delaying...."

ifcfg-wlan0 is identical to known good config for smp kernels.  Have
tried several versions of ndiswrapper including 1.15 with same result.

Have tried 2054 and 2096 64 bit kernels with same result.

FWIW, CentOS 4.3 64 bit kernels give same result.  Yet, it works without
a hitch on 32 bit kernels and 32 bit smp kernels.

Would appreciate any suggestions.  Have Googled for hours without
finding anything productive.  Thanks in advance.


Fedora Core 5, Linux 2.6.16-1.2111_FC5smp athlon 14:31:12 up 4 min, 2
users, load average: 0.49, 0.85, 0.41

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]