[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Starnge network issue: TCP doesn't work, UDP does



Michael Merwitz wrote:
OK, so there's an incorrectly configured something or other on my FC machine
that dtops TCP from working but allows UDP to work just fine.
I've run through all of the rlevant tools (netstat, tcpdump, ifconfog etc
etc.), and compared it to anthother machine running FC5, but cannot for the
life of me spot the difference.

For example, using firefox to view slashdot, I see the standard UDP traffic
for DNS.
Then, TCP SYN from my machine to their srver, ans SYN,ACK from them back to me, and finally an ACK from me to them. And then.... nothing. no traffic, no
response.
Interestingly, if I try & coinnect to the apache instance on this local
machine, I don't even get that far... there is no TCP traffic at all.

Also, if I try to use another TCP reliant app, Thunderbird, to connect to a local IMAP server (on the same subnet) I get the SYN/ACk/ACK setup, but no
further traffic.

I have SeLinux set as disabled
I have no iptables rules in effect.

The only thing that changed is that I did a yum update, installed a new
video card (nvdia 7300) and the appropriate driver, and rebooted...

Running 2.6.16-1.2107_FC5smp

Nuke that kernel, it was a problem child. And then reboot to 2096 long enough to
go get 2111 which is now released for FC5.

--
Cheers, Gene



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]