[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Setting default paper size in Gnome FC5

On 5/7/06, Marc Schwartz <MSchwartz mn rr com> wrote:
On Sun, 2006-05-07 at 09:00 +0100, Gavin Simpson wrote:


> As a follow-up, I also checked out libgnomeprint and the settings
> therein after a Google search suggested this. I looked in
> /usr/share/libgnomeprint/2.12.1/globals.xml and
> /usr/share/libgnomeprint/2.12.1/printers/GENERIC.xml. In the former we
> have:
>     <Option Id="Media">
>       <Option Type="List" Id="PhysicalSize" Default="A4">
>         <Item Id="A4">
>           <Name>A4</Name>
>           <Name xml:lang="am">A4</Name>
> ....
> And the latter:
> ....
>   <Settings Id="SETTINGS-000989541673031997000001">
>     <Name>Default</Name>
>     <Key Id="Engine">
>       <Key Value="gnome" Id="Backend"/>
>     </Key>
>     <Key Id="Output">
>       <Key Id="Media">
>         <Key Value="A4" Id="PhysicalSize"/>
>       </Key>
>       <Key Value="360x360" Id="Resolution"/>
>     </Key>
>     <Key Id="Transport">
>       <Key Value="lpr" Id="Backend"/>
>     </Key>
>   </Settings>
> </Printer>
> So all seems well here also. Is there a local gnome pref I need to set in ~/ ?


Thanks Marc

I have not seen anything definitive, however a Google search led me to a
SuSE list where the following thread may be of help:


Thus, you may want to look at 'man lpoptions' to consider creating a
~/.lpoptions file.

Tried this out - I had an .lpoptions file on the problem desktop.
Added media=A4. This didn't seem to do anything to help though - US
Letter still default in evince. I didn't see anything related in
bugzilla to do with printing or paper size. As this machine is in work
and I'm at home just now, I've been running stuff via a SSH session
with X forwarding. When testing if the .lpoptions addition worked, I
tried to print a pdf in evince. As this was running from a shell I
noticed the following messages:

GnomePrintCupsPlugin-Message: The ppd file for the CUPS printer
HPColourLaserJ could not be loaded.
GnomePrintCupsPlugin-Message: The ppd file for the CUPS printer
HPLaserJ could not be loaded.

So may be this has something to do with it?

Not sure why this would be required, as gnome-print/CUPS aware
applications should be picking up the default configuration, unless they
have application specific settings, which Evo and Evince do not seem to
have from what I can tell.

One other thing to consider would be to delete and re-define your
printers, in case something got messed up there.

Given the above messages, I'll try this when in work on Monday.

Beyond this, I would have to defer to others relative to what might be
happening here, including the possibility of an FC5 bug of sorts. You
might want to do a search of bugzilla.redhat.com to see if perhaps
something has been posted there that might be relevant.

Best regards,


Many thanks for your suggestions Marc. Much appreciated,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]