[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RPMs corrupted

I have a very strange problem.

RPMs become corrupted when downloading them with ftp or http under Fedora Core 4 and 5 (different partitions, same box). They are not corrupte when downloading with http under Windows XP (also same box). I have tried many mirrors, including download.fedora.redhat.com

The RPMs fail the rpm -K check and their md5sum is wrong. Only some RPMs fail, however. Some are always good, some are sometimes good, and some always fail. I cannot find a clear pattern.

However, the RPMs are fine if I download them with scp, and also seem to download fine if I gzip or rename them to something not with the .rpm suffix.

The Core 5 partition is a new, clean install. The Core4 partition has
not been updated in quite a while, but used to update fine earlier.

Doing cmp -l on the RPMs that are corrupted against good versions shows one of the two bytes 317 377 or 337 377 as differences at various positions in the RPMs. Usually each corrupt RPM only has one of these, and always at the same position for the same RPM through multiple redownloads. In one case I noticed one RPM getting an additional byte pair after a redownload but that was gone at the next redownload.

It looks like this:

  [perrin localhost ~]$ rpm -K procps-3.2.6-3.3.i386.rpm
  procps-3.2.6-3.3.i386.rpm: (SHA1) DSA SHA1 MD5 GPG NOT OK

  [perrin localhost new]$ cmp -l procps-3.2.6-3.3.i386.rpm
    5333 317 377

  [perrin localhost new]$ cmp -l gedit-2.14.2-1.fc5.1.i386.rpm
    22089 337 377
    22453 337 377
  2790177 337 377

So far I've this is what I have tried after helpful suggestions from people in #fedora on freenode:
 - memtest86 for several hours
 - changing MTU on my network interface
 - rebooting my ADSL router
 - checking ifconfig for errors or collisions
 - rpm -Va and a rootkit detector
 - rpm --import /etc/pki/rpm-gpg/*

None of this fixed the problem or showed anything suspicious.

I tried to unpack the RPMs using rpm2cpio to find what files
were changed, but found no changes in files in the checked RPMs.

Any ideas on what else I can try to figure this out, please? Thanks a lot for any help.

  - Per

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]