[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Perl-Tk doesn't work

On Wed, May 10, 2006 at 02:49:02PM +0100, Matt Davey wrote:
> On Tue, 2006-05-09 at 20:51 -0400, Derek Tattersall wrote:
> > I just upgraded to FC5 x86_64. I installed perl-Tk-804.027-11.rhfc5.at.
> > Unfortunately none of my perl-Tk scripts work any more. They all die
> > with this error:
> > 
> > 803ab0 is not a hash
> > at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Tk/MainWindow.pm line 55.
> > 
> > Does anyone know what caused this? the scripts all worked fine when I
> > had FC4 on my computer.
> For what it's worth, I installed perlTk directly from CPAN onto my fc5
> system and have not (so far) had trouble with my perlTk applications.

I also tried that. It didn't help.

The problem is with the x86_64 release. My perl-Tk scripts work fine on
an i686 machine with FC5 on it.

I now think the problem is with the X-server, not perl-Tk. If I ssh into
my x86_64 box from another linux machine and run the scripts, they work.
It is only when I try to run the scripts from the X-server on the x86_64
machine that I get this error. I am using the standard xorg packages that
the fc5 installer put on my machine. The driver is the generic svga one.

Derek Tattersall

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]