[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Cisco VPN client does not work on FC4

> Try:
> # chcon -t textrel_shlib_t /opt/cisco-vpnclient/lib/libvpnapi.so
> Repeat for any similar error you get for different libraries.
> This is an SELinux issue.
    Thanks for the reply. Your diagnosis is indeed correct. But the fix is not working for me on FC4.
When I tried your command on my FC4 as root, this command gave the error -
# chcon -t textrel_shlib_t /opt/cisco-vpnclient/lib/libvpnapi.so
chcon: failed to change context of /opt/cisco-vpnclient/lib/libvpnapi.so to root :object_r:textrel_shlib_t: Invalid argument
man or info of chcon did not give me too much info.
So  I tried to disable SELinux using the command
# setenforce 0
and the vpnclient command started working !!
I was able to logon to the network too. The problem is I don't want to disable SELinux, so what do you think should I fix in the above command to make it work in SELinux mode ?


Blab-away for as little as 1ยข/min. Make PC-to-Phone Calls using Yahoo! Messenger with Voice.
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]