[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Digital cameras and FC5



On Fri, 2006-05-12 at 23:18 -0600, Stanton Finley wrote:
> I just tried gthumb, digicam, and f-spot with my Canon Powershot (which
> worked fine and automatically in FC4 with gthumb) and I got messages
> like "Could not claim the USB device while connecting to camera". IMO
> this is a regression. Anyone have a fix?

Can't remember where I read this, but this works for me and my Canon
PowerShot S40

[bpm]$ diff -wruN 10-camera-libgphoto2.fdi /usr/share/hal/fdi/information/20thirdparty/10-camera-libgphoto2.fdi
--- 10-camera-libgphoto2.fdi    2006-05-13 09:57:42.000000000 -0500
+++ /usr/share/hal/fdi/information/20thirdparty/10-camera-libgphoto2.fdi        2006-03-08 18:06:05.000000000 -0600
@@ -1248,7 +1248,7 @@
     <match key="usb.product_id" int="12374">
      <merge key="info.category" type="string">camera</merge>
      <append key="info.capabilities" type="strlist">camera</append>
-     <merge key="camera.access_method" type="string">libgphoto2</merge>
+     <merge key="camera.access_method" type="string">proprietary</merge>
      <merge key="camera.libgphoto2.name" type="string">Canon PowerShot S40</merge>
      <merge key="camera.libgphoto2.support" type="bool">true</merge>
     </match>

-- 
Brian Millett - [ Delenn, "The Gathering"]
"Commander, you know everything about your stone garden. But clearly,
you
have not spent nearly enough time looking at it."



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]