[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Networking Bridging

David Cary Hart wrote:
On Wed, 10 May 2006 21:30:59 -0500, Justin Willmert
<justin jdjlab com> opined:
I need some help getting my network bridge to work right.

In FC4, I just added a couple lines to ifcfg-eth0 and ifcfg-eth1
and created a ifcfg-br0 file and it'd work, but in FC5, those same
steps aren't working. I don't have a clue how to go about debugging
what's going on (I've tried to look into it, but the number of
different files and programs involved in starting the network is
too much for me to handle).

If I follow the tutorial given at http://www.linuxjournal.com/article/8172 for setting up a bridge manually, the bridge will work. It just doesn't work with the network/init scripts.

My scripts look different than yours. Have you included an alias in
modprobe.conf? (alias br0 bridge). Does lsmod show "bridge?" Have you
followed the following:

	# brctl addbr br0
	# brctl addif br0 eth0
	# brctl addif br0 eth1
	# ifconfig eth0
	# ifconfig eth1
	# ifconfig br0 ip.address.here

Sorry it's taken me so long to reply. I've been really busy with school, and then when I am at home, we've been having internet problems...so finally here I am.

I added and alias line in modprobe.conf and I'm still getting the same error messages. I did find in /var/log/messages, some errors about the tulip driver, but I can't figure out what I did to generate them. Restarting the network over and over isn't seeming to create them, so I'll have to look into that further. Here are the lines I see repeated:

0000:00:0a.0: tulip_stop_rxtx() failed
0000:00:0b.0: tulip_stop_rxtx() failed
0000:00:0a.0: tulip_stop_rxtx() failed
eth0: Setting full-duplex based on MII#1 link partner capability of 45e1

Does anybody know where I've gone wrong?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]