[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: D-BUS/Qt3 bindings

> Erm. My mistake - I was being a dumb ass (didn't notice it was an
> src.rpm)....

OK, Here is where I have got. (I am somewhat new at this rpm building game, so 
please bear with me)...

I built the rpms from the src.rpms by 

1. rpm -ivh /data/download/dbus-qt-0.61-0.1.src.rpm
2. fedora-buildrpmtree
3. rpmbuild -bb --target=$(arch) ~/rpmbuild/SPECS/dbus-qt-fc5.spec

( for those interested, the full log file for the rpm build is here
http://www.hep.phy.cam.ac.uk/~jonesc/log.txt - maybe someone can spot some 

then, as root

4. cd /home/jonesc/rpmbuild/RPMS/i686/
5. rpm -ivh dbus-qt-0.61-0.1.i686.rpm dbus-qt-devel-0.61-0.1.i686.rpm

This seemed to work OK. However, if I try then  to build knetworkmamanger I 
still get during ./configure

checking for D-BUS... checking for dbus-1 >= 0.33, hal, libnm-util... yes
checking dbus/connection.h usability... no
checking dbus/connection.h presence... no
checking for dbus/connection.h... no
configure: WARNING: You need D-BUS/Qt3 bindings
checking for main in -lsynaptics... no
checking for libgcrypt-config... /usr/bin/libgcrypt-config
checking for LIBGCRYPT - version >= 1.1.98... yes
checking LIBGCRYPT API version... okay
checking for X11/XKBlib.h... yes
checking if knetworkmanager should be compiled... no

So if seems D-BUS/Qt3 is still not found. If I 

 > jonesc localhost ~/rpmbuild/SPECS > locate dbus/connection.h
 > /usr/include/dbus-1.0/dbus/connection.h

so it is there (and wasn't before installing the rpms). If I then try

> ./configure  --with-extra-includes=/usr/include/dbus-1.0   

I get the same error...

OK, so I am sure I am doing something wrong, but as a newbie to this rpm 
building game,  I am not sure what. Any pointers gratefully received.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]