[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Update from FC4 to FC5 stole my kernel

Karl Larsen wrote:
Frank Cox wrote:
I just ran an upgrade on a "generic" FC4 installation to update it to FC5 off of a set of cdroms. Everything seemed to go ok, but when I reboot at the end of the installation instead of the pretty graphic Grub screen that I've had up until now, I get the text-only Grub screen. The only kernel listed on the screen is the SMP kernel, the single-processor kernel is not listed at all.
When it tries booting, I get "Error 15 - File not found".

I tried upgrading again and it goes through some of the motions but I still end
up at the same place.
I can boot the rescue mode and see the filesystem on the hard drvie.

Where do I go from here?

Perhaps the issue you're seeing is the one described here:

  Note from LuyaTshimbalanga: some Fedora Core users who use dual-boot
  encountered strange issue with GRUB. After installing Fedora Core
  Release 5, GRUB won't load menu and will go to prompt mode. If it
  happens, boot FC5 disc 1 or Rescue Disc, make sure to enter "chroot
  /mnt/sysimage" in command line then do
  "grub-install /dev/hda --recheck" to fix the problem.
  Original issue from [WWW]


I had the same problem. It seems that you NEVER update anything with FC5. That process is broken. It looked real odd on my laptop FC4 to FC5 but it worked for some reason. That made me try on this computer where it failed and come to think of it Grub on the laptop had just 2 entries.

   But it appears in general that FC5 will screw up any upgrade.

Strange, it didn't screw up any of the 4 machines I upgraded from FC4 to FC5. And that includes a couple of dual-boot machines.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]