[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: cups broadcasting through a gateway



On Mon, 2006-05-22 at 04:49 +1000, Daniel Hedlund wrote:
> Gregory,
> > BrowsePoll RemoteA:631
> > BrowsePoll RemoteB:631
> >
> > BrowseRelay RemoteA 10.0.0.255
> > BrowseRelay RemoteB 10.0.0.255
> I think your problem might be with your BrowseRelay configuration 
> lines.  To relay polled servers to a local subnet, you would use the 
> localhost interface with the following syntax:
> BrowseRelay 127.0.0.1 10.0.0.255
> or
> BrowseRelay 127.0.0.1 255.255.255.255 (for a local broadcast, but not 
> sure if it restricts itself to only your local network)
> 
> Cheers,
> 
> Daniel Hedlund
> daniel digitree org

Daniel,

Thanks for your suggestion.  I tried using both suggestions but neither
of them worked, and neither of them caused any problems.  I can monitor
eth0 and eth1 on the server in question and can easily see that eth1
broadcasts the printer (lpt1) that is set up on that server, but there
is no broadcasting the information about the remote printers that are
coming in on eth0.

In my /etc/cups directory there is a subdirectory called ./interfaces
that is empty on my system.  I have not been able to find anything about
what should be placed there, but wondered if it was designed to
distinquish eth0 from eth1 etc.  

Any other ideas?

Greg


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]