[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: cups broadcasting through a gateway



Gregory,
Thanks for your suggestion.  I tried using both suggestions but neither
of them worked, and neither of them caused any problems.  I can monitor
eth0 and eth1 on the server in question and can easily see that eth1
broadcasts the printer (lpt1) that is set up on that server, but there
is no broadcasting the information about the remote printers that are
coming in on eth0
I'm not sure of your exact network set-up (each gateway directly connected to each other or spread across the Internet), but the following URLs seem to show that it's supposed to be a rather simple set-up:
http://www.easysw.com/printpro/howto.php?19#19
http://www.easysw.com/printpro/howto.php?20#20

Unfortunately, it does not seem to be that way for you. You may have been right initially with the "BrowseRelay RemoteA 10.0.0.255" type lines if your set-up is like the second URL above. Have a look and verify which configuration you're supposed to be using.

Just need to also make sure that you're restarting the cups daemon after making changes to the configuration. Other things to try include: - using IP addresses instead of hostnames as the hostnames could be resolving to internal IP addresses? - comment out the relaying and polling lines in the config, restart cups and ensure that the remote printers disappear, then add the lines back in one at a time to ensure desired results are being achieved?
- trying your CUPS configurations with 'ServerName' set to your IP address?
- trying something like "BrowseRelay 127.0.0.1 @IF(eth1)"?

Cheers,

Daniel Hedlund
daniel digitree org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]