[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: cups broadcasting through a gateway

On Mon, 2006-05-22 at 06:20 +1000, Daniel Hedlund wrote:
> Gregory,
> > Thanks for your suggestion.  I tried using both suggestions but neither
> > of them worked, and neither of them caused any problems.  I can monitor
> > eth0 and eth1 on the server in question and can easily see that eth1
> > broadcasts the printer (lpt1) that is set up on that server, but there
> > is no broadcasting the information about the remote printers that are
> > coming in on eth0
> I'm not sure of your exact network set-up (each gateway directly 
> connected to each other or spread across the Internet), but the 
> following URLs seem to show that it's supposed to be a rather simple set-up:
> http://www.easysw.com/printpro/howto.php?19#19
> http://www.easysw.com/printpro/howto.php?20#20
> Unfortunately, it does not seem to be that way for you.  You may have 
> been right initially with the "BrowseRelay RemoteA" type 
> lines if your set-up is like the second URL above.  Have a look and 
> verify which configuration you're supposed to be using.
> Just need to also make sure that you're restarting the cups daemon after 
> making changes to the configuration.  Other things to try include:
> - using IP addresses instead of hostnames as the hostnames could be 
> resolving to internal IP addresses?
> - comment out the relaying and polling lines in the config, restart cups 
> and ensure that the remote printers disappear, then add the lines back 
> in one at a time to ensure desired results are being achieved?
> - trying your CUPS configurations with 'ServerName' set to your IP address?
> - trying something like "BrowseRelay @IF(eth1)"?
> Cheers,
> Daniel Hedlund
> daniel digitree org

Thanks for taking the time to help.  The links you gave me were very
good.  The configuration I have involves is different than any of the
descriptors in the links, but there is one that is close.  

#20 describes two external networks communiating to a third that is
communicating with its own network on the same subnet.  

I have 3 separate networks and the problem I am having is broadcasting
to an internal network from a gateway machine.  The gateway machine has
eth0 set to an external IP address and eth1 set to a network address on
10.0.0.XXX.  I can see the broadcasts coming in via eth0 with ethereal,
but they are not being transmitted through eth1 to the internal network.
I installed a printer on the gateway machine and this printer is being
broadcast to the internal network as well as the external networks, but
the printers broadcasting form the remote sites are not being broadcast

The third option within the links related to sending print jobs to a
printer on a different subnet by setting up a printer internally that
points to the remote servers may have some potential.  I will play with
this a little and let you know.  

Sure do not mind your admonition to restart cups, but I have been doing
that with every change.  

Any other suggestions will be appreciated.  


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]