[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Mailing list software



On Mon, 2006-05-22 at 17:34, Todd Zullinger wrote:

> Python doesn't change that rapidly.  RH7.3 has python 2.2 and FC4/5
> has 2.4.  The currently shipped mailman package for FC4 is 2.1.5, the
> same version that I've been running on RH7.3 for a long time now.  All
> I'm saying is that version incompatibilities are not much of a problem
> in my experience and I've used mailman on numerous systems with
> varying versions of python and mailman for several years now.

How many breakages are too many?

> The only recent version incompatibility that I'm aware of is that
> mailman version newer than 2.1.6 have some parts that require python
> 2.3.  You can run it on 2.2 if you know what to tweak and aren't
> worried about some of the edge cases that require python 2.3.

Perhaps I've just been spoiled by running perl where there's
only been one syntax change in about 20 years that affected
existing code and you didn't have to know much to fix it.

-- 
  Les Mikesell
   lesmikesell gmail com



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]