[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problems w/ serial flow control

Rick Stevens wrote:
On Wed, 2006-05-31 at 12:14 -0600, Philip Prindeville wrote:
Tim wrote:
On Tue, 2006-05-30 at 21:25 -0600, Philip Prindeville wrote:
I'm running FC3 on an MSI-7142 (K8MM-V motherboard), and using
the two serial ports on the m/b.  I used the stock
out-of-the-shrinkwrap settings for most hardware (except for the sound
board and X drivers), and things have worked fine.

But... when connecting to a router's console at 115200 with either
RTS/CTS or XON/XOFF flow control, I'm seeing dropped characters.
Looking at a friend's router, his one's serial port connection *ONLY*
had the three-wire type of serial connection.  So his couldn't possibly
use hardware handshaking (RTS/CTS).  Perhaps yours can't too?

Also, check what your router says about its maximum port speeds and
handshaking protocols.

It is an 8-wire connection (over RJ-45 to DB-9), and can do 115200 (max rate)
with either XON/XOFF or RTS/CTS.

I've tried both, and they're both lossy.

The issue is on the PC as the receiver...

Remember that both ends have to agree on the flow control.  If one is
running  RTS/CTS and the other is XON/XOFF, you don't have flow control.
At 115K, I'd always opt for RTS/CTS...XON/XOFF requires CPU intervention
unless you have fairly sophisticated hardware.  All you have to do is
be a bit pokey at responding to an interrupt and you'll drop characters.
RTS/CTS is usually done at the hardware level and is a bit more

I started with RTS/CTS...  And had it set on both ends.

I'm using the FC5 version of kermit.  My .kermrc looks like:

set modem type none
set line /dev/ttyS0
set carrier-watch off
set speed 115200
set flow rts/cts
set parity none
set stop-bits 1

Not sure what the difference is between "/dev/tty0" and


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]