[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: 2 versions of librsvg2 after updates on fresh install of FC5



On Saturday 30 September 2006 23:27, James Wilkinson wrote:
> Nigel Henry wrote:
> > Anyway FC5 booted up ok when the power came back, and I ran apt-get
> > update again just to check out whether everything was ok. I've got a big
> > bunch of deletes from apt-get update, and the last entry is.
> > W: There are multiple versions of "librsvg2" in your system.
> >
> > True. Looking in synaptic I have libsrvg2#2.14.2-1, and
> > libsrvg2#2.14.4-1.fc5.1 .
> >
> > /usr/lib shows librsvg-2.so.2 pointing to librsvg-2.so.2.14.4
> >
> > Is it safe to just remove the earlier librsvg2#2.14.2-1 version from the
> > system?
>
> Check libsrvg2#2.14.4-1.fc5.1 with rpm -V. If there's a problem,
> re-install it (with rpm -U --oldpackage).
>
> Then try removing the earlier package and see what happens (with rpm -e
> or rpm -e --test). If anything complains, see if you can sort it out. If
> RPM lets you, you're very unlikely to see any real problems.
>
> In any case, this is hardly a system-critical library.
>
> Hope this helps,
>
> James.

Problems here. I can't remove the earlier version, and the later version wants 
to remove half the OS along with it as deps. I've now got also since the 
updates, a problem gaining access to Gdm, as on my latest post to the list. 
Gdm lists librsvg2 as a dependency, so I think that the lack of access to gdm 
has got a lot to do with the 2 versions of librsvg2 being installed.

There is something really screwed up with the updates here.

The only way I can get into anything graphical at the moment is to boot into 
init3, and then startX which goes straight into Gnome. That's ok, but I use 
KDE, and don't know my way around Gnome so well.

This is the output error message from synaptic, when I just tried to remove 
the earlier version of librsvg2, and is almost the same message I got when 
all the updates had been installed.

While preparing for installation:

/usr/bin/update-gdk-pixbuf-loaders: line 
27: /etc/gtk-2.0/i386-redhat-linux-gnu/gdk-pixbuf.loaders: No such file or 
directory
error: %postun(librsvg2-2.14.2-1.i386) scriptlet failed, exit status 1
W: Some errors occurred while running transaction

I have no problem is saving the /var/cache/apt/archives to another drive to 
save DL'ing them again, but if I reinstall FC5, which has nothing on it, I 
can just see the same problem arising when applying the updates again.

On the fly update:

I've just removed Gdm, which has removed a load of other stuff, then 
reinstalled Gdm, which upon completion gave me the same pixbuf errors as I've 
posted above. I then shutdown, rebooted, and now have a login screen. Not the 
same one as on the initial install of FC5, but who cares. It's quite plain, 
but gives me the option to choose Gnome or KDE.

I must admit that I'm a bit puzzled. I still have 2 versions of librsvg2 
installed, and cannot remove either of them, but at least I have gdm back, 
and am able to get into KDE.

I've used FC since FC1, and still have FC1 on both machines, I use from day to 
day FC2 with no problems, even though both are no longer supported. All I can 
say is that updates shouldn't prevent you booting up. FC5 isn't succeeding at 
that, at the moment.

Anyway. I've got got FC5 working again, so, so be it.

Nigel.



>
> --
> E-mail:     james@ | We're beginning to see the results of bringing a
> rubber aprilcottage.co.uk | chicken to a nuclear battle.
>
>                    |     -- "Whitefang", on groklaw.net


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]