[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Gdm won't start after updates on FC5



Nigel Henry wrote:


Hi Jim. This whole problem seems to have been caused by updates having installed another version of librsvg2, so I ended up with.
librsvg2     2.14.4-1.fc5.1      (the correct one)
and
librsvg2 2.14.2-1 (an earlier version, which shows up on the versions list in synaptic)

I had a version with fc5 left on my system along with the fc6 version installed via a yum upgrade to fc6. I removed only the database entry with rpm.


No third party repo's were involved in the updates, just the 3 which came with apt (core, updates, and extras).

I could not remove the earlier version, and kept getting a transaction failed because part of the removal meant getting access to /etc/gtk-2.0/i686-redhat-linux-gnu/gdk-pixbuf.loaders, and the transaction failed message said it was looking for the gdk-pixbuf.loaders file in /etc/gtk-2.0/i386-redhat-linux-gnu.

To remove the earlier version of librsvg2, I've had to create a link in /etc/gtk-2.0 to trick synaptic into thinking that "i386-redhat-linux-gnu" exists.

For future reference, the program rpm has options to force package removal, just remove the database entry, install older versions of packages. This is probably better than needing to make links. It worked for you, so the end result matters most.

#cd /etc/gtk-2.0
ln -s i686-redhat-linux-gnu i386-redhat-linux-gnu

Now librsvg 2.14.2-1 removes ok, and I think I'll leave the link there for the time being in case there are any more problems.

To be sure that some of the files needed for the version left installed were not removed with removing the dual version of librsvg2, you might want to rpm -qV librsvg2 for this package to see if anything fails the test. If the results come back blank, it verified OK. If it is missing any files, rpm has options such as --replacefiles and --replacepkgs which will overwrite any files with the package content ones. This will fix the package to being complete.


Prior to doing the above removal, I'd removed gdm, and next time I booted I got a different display manager, a plain blue one with Fedora on it, but no bubbles, and the login box in the centre of the screen. I'm presuming it is kdm.

There is gdm, kdm and xdm. If you installed the default software, kdm is not installed, you probably are seeing xdm. It is plain but does its job with no frills.


I've still got to try reinstalling gdm, to see if it works now, but I'm not too bothered, because at least I have a login screen.

That's what matters.


Thanks for your help.
No problem.

Nigel.



--
Obviously I was either onto something, or on something.
             -- Larry Wall on the creation of Perl


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]